Bug 1248474 - Multiple GPU crashes and X hungs with radeonsi from kernel 3.17 and onwards
Multiple GPU crashes and X hungs with radeonsi from kernel 3.17 and onwards
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
22
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-30 07:32 EDT by Dm3 K
Modified: 2015-08-10 04:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-10 04:38:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
glxinfo output (60.11 KB, text/plain)
2015-07-30 07:32 EDT, Dm3 K
no flags Details
journalctl -b -1 (904.86 KB, text/plain)
2015-07-30 07:32 EDT, Dm3 K
no flags Details
dmesg with drm.debug (132.57 KB, text/plain)
2015-07-30 07:33 EDT, Dm3 K
no flags Details
lspci -nn (2.87 KB, text/plain)
2015-07-30 07:34 EDT, Dm3 K
no flags Details
xorg log (89.89 KB, text/plain)
2015-07-30 07:34 EDT, Dm3 K
no flags Details
Example of OpenGL crash (java/minecraft) (356 bytes, text/plain)
2015-07-30 07:35 EDT, Dm3 K
no flags Details

  None (edit)
Description Dm3 K 2015-07-30 07:32:07 EDT
Created attachment 1057628 [details]
glxinfo output

I've tried my best to follow the debug recommendations from the Fedora wiki (https://fedoraproject.org/wiki/How_to_debug_Xorg_problems). I am open to providing any more required log files and command outputs on demand. 

Description of problem:
A series of different GPU related crashes that began from kernel version 3.17 and onwards. These include: 

* X server hangs completely (especially during fullscreen HTML5 video (Firefox), or fullscreen OpenGL apps). Usually and audio sample will keep looping while X is completely unresponsive - no option to switch to a different tty. 

* X server is killed and restarted (to xfce login screen) - mostly while using Firefox

* OpenGL applications crash seemingly randomly 

* Firefox crashes seemingly randomly 

* Pulseaudio crashes during video playback (VLC/HDMI audio)


Version-Release number of selected component (if applicable):
Name        : xorg-x11-drv-ati
Arch        : x86_64
Epoch       : 0
Version     : 7.5.0
Release     : 3.fc22

Name        : kernel
Arch        : x86_64
Epoch       : 0
Version     : 4.1.2
Release     : 200.fc22


How reproducible:

Difficult to reproduce because crashes although often (multiple times in a session, with irregular intervals) do not seem to be predictable. X server lock is less common even (a couple of times in a day). 


Steps to Reproduce:
1. Use AMD GPU requiring radeonsi
2. Use OpenGL applications or render HTML5 video in browser
3. Wait random amount of time

Actual results:
One of the following
* X server hangs completely

* X server restarts

* OpenGL applications 

* Firefox crashes

* Pulseaudio crashes


Expected results:
X and the applications do not crash. 

Additional info:

OS: Fedora 22 x68_64 XFCE (upgraded from 20-->21-->22 with fedup)

GPU: AMD Radeon HD 7750

Monitor configuarion: HDMI screen - with HDMI Audio (pulseaudio)

GPU Video Acceleration in VLC/HTML5 is NOT used. 

There's no xorg.conf, contents of xorg.conf.d are:
00-keyboard.conf
09-msttcore-fontpath.conf
Comment 1 Dm3 K 2015-07-30 07:32:56 EDT
Created attachment 1057629 [details]
journalctl -b -1
Comment 2 Dm3 K 2015-07-30 07:33:59 EDT
Created attachment 1057630 [details]
dmesg with drm.debug
Comment 3 Dm3 K 2015-07-30 07:34:19 EDT
Created attachment 1057631 [details]
lspci -nn
Comment 4 Dm3 K 2015-07-30 07:34:46 EDT
Created attachment 1057632 [details]
xorg log
Comment 5 Dm3 K 2015-07-30 07:35:54 EDT
Created attachment 1057633 [details]
Example of OpenGL crash (java/minecraft)
Comment 6 Dm3 K 2015-08-10 04:38:04 EDT
Everything points towards a hardware problem.

Note You need to log in before you can comment on or make changes to this bug.