Bug 1248636 - Candlepin should communicate with broker over "ANONYMOUS"
Candlepin should communicate with broker over "ANONYMOUS"
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Candlepin (Show other bugs)
Unspecified
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
: Triaged
Depends On: 1314904 1357596
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-30 09:55 EDT by Corey Welton
Modified: 2016-12-08 15:16 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-08 15:16:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Welton 2015-07-30 09:55:19 EDT
SNAP 15

See the following bug comment: 
https://bugzilla.redhat.com/show_bug.cgi?id=1245657#c22

"They must also be using SSL connections because the broker config requires it, so I think having them switch to ANONYMOUS would be safe and good. It will help them avoid any low-level sasl library prompting in cases where PLAIN is used and either the username or password are blank or empty."

Essentially, most services for satellite now communicate with the amqp over "Anonymous".  Candlepin's java client, however, is not.
Comment 2 Bryan Kearney 2016-07-08 16:47:07 EDT
Per 6.3 planning, moving out non acked bugs to the backlog
Comment 4 Barnaby Court 2016-12-05 14:12:43 EST
Fixed upstream in candlepin-0.9.54.9-1 and candlepin-2.0.14-1

Note You need to log in before you can comment on or make changes to this bug.