Bug 1248749 - Products in My Subscriptions tab and All Available Subscriptions takes awhile to match
Products in My Subscriptions tab and All Available Subscriptions takes awhile...
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.2
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: candlepin-bugs
John Sefler
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-30 14:22 EDT by Sean Toner
Modified: 2015-12-02 08:21 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-02 08:21:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
shows the All Available Subscriptions product info vs. My Subscriptions (524.25 KB, application/x-gzip)
2015-07-30 14:22 EDT, Sean Toner
no flags Details

  None (edit)
Description Sean Toner 2015-07-30 14:22:53 EDT
Created attachment 1057801 [details]
shows the All Available Subscriptions product info vs. My Subscriptions

Description of problem:
=======================

If a user looks at the All Available Subscriptions tab, selects a subscription, and checks the Products information, this should be the same as appears under the My Subscriptions tab.  However, after newly attaching a subscription, it can take a minute or two for all the products to show up in the My Subscriptions tab.  This may be disconcerting to customers


Version-Release number of selected component (if applicable):
=============================================================

subscription-manager-gui-1.15.6-1.el7.x86_64

How reproducible:
=================

Sometimes

Steps to Reproduce:
===================

1. Select All Available Subscriptions tab
2. Select a subscription with a lot of products (eg Employee SKU)
3. Click the Attach button and select OK to attach
4. Once finished, select the My Subscriptions tab
5. Select the subscription in top half, and observe product information

Actual results:
===============

Sometimes, the product info does not match right away.  Eventually it appears that the information will display all products.  Sometimes all the products will appear as soon as you go to the My Subscriptions tab though

(see screenshot)

Expected results:
=================

Content of the products should be the same

Additional info:
Comment 2 John Sefler 2015-09-25 12:22:58 EDT
deferring to rhel-7.3.0 due to schedule and severity
Comment 4 J.C. Molet 2015-12-02 08:21:32 EST
With the latest subscription-manager-gui-1.15.9-15.el7.x86_6 this does not seem to be an issue. After attaching a subscription I do not notice any lag in the My Subscriptions tab. Tried this on both a local candlepin instance, as well as production

Note You need to log in before you can comment on or make changes to this bug.