Bug 1248762 - ActionController::RoutingError (No route matches [GET] "/favicon.ico"):
ActionController::RoutingError (No route matches [GET] "/favicon.ico"):
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.1.5
Unspecified Unspecified
unspecified Severity low (vote)
: 6.1.1
: --
Assigned To: satellite6-bugs
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-30 14:52 EDT by Thom Carlin
Modified: 2017-02-07 13:49 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-02-07 13:49:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thom Carlin 2015-07-30 14:52:57 EDT
Description of problem:

"ActionController::RoutingError (No route matches [GET] "/favicon.ico"):" in /var/log/foreman/production.log

Version-Release number of selected component (if applicable):

6.1 beta

How reproducible:

Frequent

Steps to Reproduce:
1. Install components
2. view /var/log/foreman/production.log
3.

Actual results:

2015-07-30 12:32:27 [F] 
ActionController::RoutingError (No route matches [GET] "/favicon.ico"):
  /usr/share/gems/gems/passenger-4.0.18/lib/phusion_passenger/rack/thread_handler_extension.rb:77:in `process_request'
  /usr/share/gems/gems/passenger-4.0.18/lib/phusion_passenger/request_handler/thread_handler.rb:140:in `accept_and_process_next_request'
  /usr/share/gems/gems/passenger-4.0.18/lib/phusion_passenger/request_handler/thread_handler.rb:108:in `main_loop'
  /usr/share/gems/gems/passenger-4.0.18/lib/phusion_passenger/request_handler.rb:441:in `block (3 levels) in start_threads'

Expected results:

No error

Additional info:

Low priority since it is an icon.
Comment 1 John Matthews 2015-08-12 11:28:15 EDT
Joseph,

Please see if this should be reassigned to Satellite.
Comment 2 jmagen@redhat.com 2015-12-15 07:51:59 EST
yes, reassign to Satellite. I don't see this in my log/production.log but if so, it's a not a fusor/rhci issue
Comment 3 Thom Carlin 2016-03-29 09:12:24 EDT
For TP3 RC2, I see this in /var/log/foreman/deployments/<name>-<number>/var/log/foreman/production.log (from refarch issue where it hangs in RHEV at 87.5%).  Attaching log
Comment 5 Bryan Kearney 2016-07-26 15:11:37 EDT
Moving 6.2 bugs out to sat-backlog.
Comment 8 Bryan Kearney 2017-02-07 13:49:47 EST
I do not see this bug being addressed in the near future. I am closing this as WONTFIX. If you believe this is in error, please feel free to re-open with business justification.

Note You need to log in before you can comment on or make changes to this bug.