Bug 1248765 - Cannot Print on Different Papers
Cannot Print on Different Papers
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
24
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Zdenek Dohnal
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-30 14:53 EDT by Paul Finnigan
Modified: 2016-12-23 05:44 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-23 05:44:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from printer troubleshooter in system-config-printer (32.06 KB, text/plain)
2015-07-30 14:53 EDT, Paul Finnigan
no flags Details
Output from journalctl -u cups.service -b 0 (1.08 MB, text/plain)
2015-07-31 16:56 EDT, Paul Finnigan
no flags Details
Print on Plain Paper (19.35 KB, text/plain)
2015-07-31 16:57 EDT, Paul Finnigan
no flags Details
Print on Inkjet Paper (15.50 KB, text/plain)
2015-07-31 16:58 EDT, Paul Finnigan
no flags Details
Command output - commands are shown before oputput in file (1.54 KB, text/plain)
2015-07-31 16:59 EDT, Paul Finnigan
no flags Details

  None (edit)
Description Paul Finnigan 2015-07-30 14:53:22 EDT
Created attachment 1057826 [details]
Output from printer troubleshooter in system-config-printer

Description of problem:

I have a Brother MFC-J6520DW, purchased because they supplied a Linux driver. Everything worked well until Fedora 22. Since then I cannot select any paper type other than Plain Paper in the printer options, even if I have selected the same paper type on the printer.

When using any other paper type than plain the driver reports everything has completed but the printer does not print, complaining about data remaining in memory, eventually a blank page is ejected. The print troubleshooter does recognise that the print was unsuccessful! 

If you use plain paper then the print is fine.

I have attached the output from the troubleshooter.


Version-Release number of selected component (if applicable):

cups.x86_64  1:2.0.3-1.fc22

How reproducible:
Everytime


Steps to Reproduce:
1. Print a document on something other than plain paper
2.
3.

Actual results:
A blank page

Expected results:
A printed document

Additional info:

I have reported this to brother who (naturally) say it is an "OS problem"
Comment 1 Jiri Popelka 2015-07-31 05:57:10 EDT
(In reply to Paul Finnigan from comment #0)
> I have a Brother MFC-J6520DW, purchased because they supplied a Linux driver.

I don't see this printer in http://www.openprinting.org/printers database so I guess you're using the driver directly from Brother, right ?

Could you try to obtain some more log messages via
https://fedoraproject.org/wiki/How_to_debug_printing_problems#Getting_debug_information_by_other_means


> If you use plain paper then the print is fine.

Setting Severity to urgent can actually have opposite effect in that case ;-)
(/me couldn't resist to nitpick)
Comment 2 Paul Finnigan 2015-07-31 16:56:34 EDT
Created attachment 1058159 [details]
Output from  journalctl -u cups.service -b 0
Comment 3 Paul Finnigan 2015-07-31 16:57:44 EDT
Created attachment 1058161 [details]
Print on Plain Paper
Comment 4 Paul Finnigan 2015-07-31 16:58:42 EDT
Created attachment 1058162 [details]
Print on Inkjet Paper
Comment 5 Paul Finnigan 2015-07-31 16:59:39 EDT
Created attachment 1058163 [details]
Command output - commands are shown before oputput in file
Comment 6 Paul Finnigan 2015-07-31 17:20:31 EDT
First I am using a printer driver provided by Brother. This has worked on previous releases of Fedora (20 and 21) without problems, I am not claiming that this stops the driver is at fault I just mention that it is a new problem.

I have attached the logs suggested by the debugging printer problems page. I have shown the output from the last boot (I rebooted for the tests). I printed the same page from LibreOffice 4 times using:

Job 116 - "Plain Paper" - printed OK
Job 117 - "Inkjet Paper" - blank page printed
Job 118 - "Other Photo Paper" - blank page printed
Job 119 - "Plain Paper" - printed OK

I have only included the logs for the first two jobs. If you want the others then let me know.

I can also tell you that the same problem occurs when printing from the Gimp and Eye of Gnome Image Viewer. My printer can connect via USB, Ethernet or wireless. I currently don't have it connected on Ethernet as I have no free ports but the same problem occurs via wireless or USB. The examples are via wireless. I also have the problem on two Fedora systems that I use with the printer.

As to the urgent flag, it was a typo. I thought I had put high. I could do with getting this fixed in the next few weeks if possible as I need to produce some presentations on glossy paper for mid-August. 

I can always use a fallback, print it using my Android phone which works but misses out on the use of icc profiles. So perhaps even high was a little OTT. I will think before I select this in future.
Comment 7 Fedora Admin XMLRPC Client 2016-06-24 06:29:57 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 8 Fedora End Of Life 2016-07-19 14:55:08 EDT
Fedora 22 changed to end-of-life (EOL) status on 2016-07-19. Fedora 22 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 9 Paul Finnigan 2016-07-24 15:09:12 EDT
The problem also happens on Fedora 23 and Fedora 24.
Comment 10 Paul Finnigan 2016-12-04 09:24:45 EST
This problem has been outstanding since F22 but appears to be fixed in F25.

The brother (non-open) driver has not been altered.

The working configuration uses

cups.x86_64     1:2.2.0-4.fc25
kernel.x86_64   4.8.10-300.fc25

As far as I am concerned the problem can be closed as fixed in F25. However the maintainers may like to look at the differences in version 1:2.0 to 1:2.2 to see what may have caused the problems.
Comment 11 Zdenek Dohnal 2016-12-23 05:44:09 EST
Hi Paul,

thanks for letting me know. Closing as CURRENTRELEASE. I will look into it.

Note You need to log in before you can comment on or make changes to this bug.