Bug 1248852 - RFE: compile with OpenGL support
RFE: compile with OpenGL support
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: fltk (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-30 21:45 EDT by Ranjan Maitra
Modified: 2015-07-31 10:56 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-31 10:56:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ranjan Maitra 2015-07-30 21:45:09 EDT
fltk on Fedora does not appear to be configured with OpenGL support. It would be good to have this functionality so that packages and applications using FLTK and OpenGL can be developed.
Comment 1 Rex Dieter 2015-07-31 10:23:27 EDT
> fltk on Fedora does not appear to be configured with OpenGL support.

Why do you say that?

(As far as I can tell, that assertion is untrue)
Comment 2 Ranjan Maitra 2015-07-31 10:35:20 EDT
I apologize if this is not true, but I was trying to compile pyFltk 

https://pypi.python.org/pypi/pyFltk

and while compiling, I got:

FLTK was configured without multi-threading support!
FLTK was configured without OpenGL support!
FLTK was configured with Forms support!

Therefore, I assumed that fltk was configured without openGl. I am not sure what the problem is. Thanks!
Comment 3 Rex Dieter 2015-07-31 10:37:58 EDT
OK, I'll look into how pyFltk determines that, and let you know if I find anything.
Comment 4 Ranjan Maitra 2015-07-31 10:53:00 EDT
Btw, you may need to do the following to make pyFltk work (as per the author) because I had to do this in Fedora 22:

First, simply delete the file browserData.py, this is not crucial. [This file is in test/].

Next, please add the following line

int _fl_filename_isdir_quick(const char* n)  { return 0; }

to file python\fltk_wrap.cpp

Perhaps we can have this in as a rpm if things work.

Many thanks!
Comment 5 Rex Dieter 2015-07-31 10:56:49 EDT
pyFltk's setup.py is arguably broken/naive, it makes some invalid assumptions:

* theading support implies explicit -lpthreads linking in 'fltk-config --ldflags' output
* opengl support implies explicit -lGL linking in 'fltk-config --ldflags' output

neither of which is necessarily true (or needed) when using shared libraries

Note You need to log in before you can comment on or make changes to this bug.