Bug 124898 - rmap problem in smp kernel
rmap problem in smp kernel
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-01 06:22 EDT by Igor Pesando
Modified: 2015-01-04 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-18 22:58:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Igor Pesando 2004-06-01 06:22:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.2)
Gecko/20040308

Description of problem:
Since I'm not a kernel expert I can only show the log

May 31 18:26:31 to41w2 kernel: Badness in page_referenced_file at
mm/rmap.c:354
May 31 18:26:31 to41w2 kernel: Call Trace:
May 31 18:26:31 to41w2 kernel:  [<02145fa2>] page_referenced+0x2f6/0x316
May 31 18:26:31 to41w2 kernel:  [<0213da32>] shrink_list+0xf0/0x4cd
May 31 18:26:31 to41w2 kernel:  [<0213e03b>] shrink_cache+0x22c/0x3cd
May 31 18:26:31 to41w2 kernel:  [<0213eacf>] balance_pgdat+0x14f/0x243
May 31 18:26:31 to41w2 kernel:  [<0213eccc>] kswapd+0x109/0x10b
May 31 18:26:31 to41w2 kernel:  [<0211ca4d>]
autoremove_wake_function+0x0/0x28
May 31 18:26:31 to41w2 kernel:  [<0211ca4d>]
autoremove_wake_function+0x0/0x28
May 31 18:26:31 to41w2 kernel:  [<0213ebc3>] kswapd+0x0/0x10b
May 31 18:26:31 to41w2 kernel:  [<021041f1>] kernel_thread_helper+0x5/0xb
May 31 18:26:31 to41w2 kernel:


Version-Release number of selected component (if applicable):
kernel-2.6.5-1.358 smp

How reproducible:
Didn't try


Additional info:
Comment 1 Arjan van de Ven 2004-06-01 06:26:52 EDT
which kernel modules are in use ?
Comment 2 Igor Pesando 2004-06-01 06:32:48 EDT
lsmod reports:
Module                  Size  Used by
ppp_generic            26132  0
slhc                    9600  1 ppp_generic
parport_pc             23616  1
lp                     12300  0
parport                34632  2 parport_pc,lp
autofs4                15488  0
sunrpc                110280  1
3c59x                  34984  0
floppy                 52336  0
sg                     32288  0
microcode              10400  0
dm_mod                 37536  0
uhci_hcd               28188  0
ipv6                  214624  20
ext3                  108136  2
jbd                    50328  1 ext3
aic7xxx               141752  3
sd_mod                 20352  4
scsi_mod               97224  3 sg,aic7xxx,sd_mod


I think it could be a problem related to the serial port since I have
been having problem with it too and using setserial to set the
baudrate I have got
May 31 23:42:17 to41w2 kernel: divide error: 0000 [#1]
May 31 23:42:17 to41w2 kernel: SMP
May 31 23:42:17 to41w2 kernel: CPU:    1
May 31 23:42:17 to41w2 kernel: EIP:    0060:[<021ea4f1>]    Not tainted
May 31 23:42:17 to41w2 kernel: EFLAGS: 00010246   (2.6.5-1.358smp)
May 31 23:42:17 to41w2 kernel: EIP is at uart_get_divisor+0x25/0x28
May 31 23:42:17 to41w2 kernel: eax: 00096000   ebx: 0240a620   ecx:
00000000   edx: 000000
00
May 31 23:42:17 to41w2 kernel: esi: 00000000   edi: 00000000   ebp:
15e50000   esp: 0fe25e
54
May 31 23:42:17 to41w2 kernel: ds: 007b   es: 007b   ss: 0068
May 31 23:42:17 to41w2 kernel: Process pppd (pid: 1020,
threadinfo=0fe25000 task=0711b9b0)
May 31 23:42:17 to41w2 kernel: Stack: 021ee173 0240a620 17eb5444
021ee1fd 00000000 0000960
0 02305620 13005620
May 31 23:42:17 to41w2 kernel:        02305620 0240a620 0fe25eb4
15e50000 021ea551 15e5000
0 0fe25eb4 17eb5468
May 31 23:42:17 to41w2 kernel:        021eb3e8 800018b2 19f69200
15e50000 00000000 17eb546
8 00000000 021d63af
May 31 23:42:17 to41w2 mgetty[978]: mdm_read_byte: read returned 0:
Success
May 31 23:42:17 to41w2 kernel: Call Trace:
May 31 23:42:17 to41w2 mgetty[978]: wfr: error in read(): Success
May 31 23:42:17 to41w2 kernel:  [<021ee173>]
serial8250_get_divisor+0x3c/0x43
May 31 23:42:17 to41w2 mgetty[978]: mdm_read_byte: read returned 0:
Success
May 31 23:42:17 to41w2 kernel:  [<021ee1fd>]
serial8250_set_termios+0x83/0x29d
May 31 23:42:17 to41w2 mgetty[978]: wfr: error in read(): Success
May 31 23:42:17 to41w2 kernel:  [<021ea551>] uart_change_speed+0x5d/0x61
May 31 23:42:17 to41w2 mgetty[978]: missed ringback!
May 31 23:42:17 to41w2 kernel:  [<021eb3e8>] uart_set_termios+0x53/0x136
May 31 23:42:17 to41w2 mgetty[978]: tcgetattr failed: Input/output error
May 31 23:42:17 to41w2 kernel:  [<021d63af>] change_termios+0x142/0x157
May 31 23:42:17 to41w2 mgetty[978]: tcsetattr failed: Input/output error
May 31 23:42:17 to41w2 kernel:  [<021d64cf>] set_termios+0x10b/0x117
May 31 23:42:17 to41w2 mgetty[978]: tcsetattr failed: Input/output error
May 31 23:42:17 to41w2 kernel:  [<02118c2b>] do_page_fault+0x133/0x4b4
May 31 23:42:17 to41w2 mgetty[978]: mdm_read_byte: read returned 0:
Success
May 31 23:42:17 to41w2 kernel:  [<021d66ce>] n_tty_ioctl+0x79/0x2ef
May 31 23:42:17 to41w2 mgetty[978]: wfr: error in read(): Success
May 31 23:42:17 to41w2 kernel:  [<021eb343>] uart_ioctl+0xff/0x151
May 31 23:42:17 to41w2 mgetty[978]: mdm_read_byte: read returned 0:
Success
May 31 23:42:17 to41w2 kernel:  [<021d3471>] tty_ioctl+0x344/0x35d
May 31 23:42:17 to41w2 mgetty[978]: wfr: error in read(): Success
May 31 23:42:17 to41w2 kernel:  [<0215d98a>] sys_ioctl+0x207/0x243
May 31 23:42:17 to41w2 mgetty[978]: missed ringback!
May 31 23:42:17 to41w2 kernel:
May 31 23:42:17 to41w2 mgetty[978]: tcgetattr failed: Input/output error
May 31 23:42:17 to41w2 kernel: Code: f7 f1 c3 57 89 c1 89 d7 56 53 8b
40 10 8b 71 14 8b 10
 85 d2


Comment 3 Dave Jones 2004-10-25 23:42:22 EDT
are things any better with teh errata kernel ?

Note You need to log in before you can comment on or make changes to this bug.