Bug 1249023 - Package tuned-profiles-realtime should be optional
Package tuned-profiles-realtime should be optional
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: releng (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Lubos Kocman
Release Test Team
:
Depends On:
Blocks: 1295396 1305230
  Show dependency treegraph
 
Reported: 2015-07-31 07:11 EDT by Tereza Cerna
Modified: 2017-02-02 06:20 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-02-02 06:20:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Builds in errata. See that profile-nfv is not dependent on profile-realtime. (34.60 KB, image/png)
2015-07-31 07:17 EDT, Tereza Cerna
no flags Details

  None (edit)
Description Tereza Cerna 2015-07-31 07:11:49 EDT
Package tuned-profiles-realtime is now only for 7Server-RT and package tuned-profiles-nfv is 7*-Optional. Both packages should be Optional because profile nfv is dependent on realtime profile.
tuna <- profiles-realtime <- profiles-nfv

This problem is shown in attachment. It is screen from builds in tuned errata.

Version of packages:
tuned-profiles-realtime-2.5.0-1.el7.noarch
tuned-profiles-nfv-2.5.0-1.el7.noarch
Comment 2 Tereza Cerna 2015-07-31 07:17:05 EDT
Created attachment 1058032 [details]
Builds in errata. See that profile-nfv is not dependent on profile-realtime.
Comment 7 Lubos Kocman 2017-02-02 06:20:31 EST
Closing as current release, since these packages has been placed into Server-NFV variant.

-bash-4.1$ ~/bin/locate-rhel7-rpms tuned | grep Server | grep x86
Server/x86_64/os/Packages/tuned-2.7.1-3.el7_3.1.noarch.rpm
Server/x86_64/os/Packages/tuned-utils-2.7.1-3.el7_3.1.noarch.rpm
Server-NFV/x86_64/os/Packages/tuned-profiles-nfv-2.7.1-3.el7_3.1.noarch.rpm
Server-NFV/x86_64/os/Packages/tuned-profiles-realtime-2.7.1-3.el7_3.1.noarch.rpm
Server-RT/x86_64/os/Packages/tuned-profiles-realtime-2.7.1-3.el7_3.1.noarch.rpm
Server-SAP/x86_64/os/Packages/tuned-profiles-sap-2.7.1-3.el7_3.1.noarch.rpm
Server-SAPHANA/x86_64/os/Packages/tuned-profiles-sap-hana-2.7.1-3.el7_3.1.noarch.rpm
Server-optional/x86_64/os/Packages/tuned-gtk-2.7.1-3.el7_3.1.noarch.rpm
Server-optional/x86_64/os/Packages/tuned-profiles-atomic-2.7.1-3.el7_3.1.noarch.rpm
Server-optional/x86_64/os/Packages/tuned-profiles-compat-2.7.1-3.el7_3.1.noarch.rpm
Server-optional/x86_64/os/Packages/tuned-profiles-oracle-2.7.1-3.el7_3.1.noarch.rpm
Server-optional/x86_64/os/Packages/tuned-utils-systemtap-2.7.1-3.el7_3.1.noarch.rpm

Note You need to log in before you can comment on or make changes to this bug.