Bug 1249086 - need documentation on hardening policy.json
need documentation on hardening policy.json
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation (Show other bugs)
6.0 (Juno)
All Linux
medium Severity medium
: z1
: 7.0 (Kilo)
Assigned To: Radek Bíba
: Documentation, ZStream
Depends On:
Blocks: 1265075
  Show dependency treegraph
 
Reported: 2015-07-31 09:14 EDT by Pratik Pravin Bandarkar
Modified: 2016-02-11 08:41 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-10 05:41:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pratik Pravin Bandarkar 2015-07-31 09:14:03 EDT
Description of problem:
All openstack services have policy.json file which is used to control which user can access which objects in which way. But, the information about how to configure it is missing. i.e. what is possible, what is configurable, what is the syntax and what we cannot touch. It would be great if we can have detail documentation on the same. 

From upstream doc: http://docs.openstack.org/kilo/config-reference/content/policy-json-file.html

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:



Expected results:


Additional info:
Comment 3 Andrew Dahms 2015-08-02 20:46:47 EDT
Assigning to Radek for review.

Radek - this bug concerns the policy.json files we discussed a week or so back, so I am assigning to you to follow up on as part of that work.
Comment 13 Radek Bíba 2015-09-10 05:41:18 EDT
OK, I'm closing this bug as "current release" because the format of the policy.json files is already described in our docs. If any specific options are to be added to the docs, it'll be done via bug 947649. (But please keep in mind that there are about a thousand entries in all the policy.json files.)

Note You need to log in before you can comment on or make changes to this bug.