Bug 1249125 - Add a note about irqbalance and isolcpus
Add a note about irqbalance and isolcpus
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: doc-Realtime_Tuning_Guide (Show other bugs)
7.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Maxim Svistunov
ecs-bugs
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-31 10:43 EDT by Daniel Bristot de Oliveira
Modified: 2016-01-27 08:34 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-27 08:34:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Bristot de Oliveira 2015-07-31 10:43:48 EDT
Document section:
https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux_for_Real_Time/7/html/Tuning_Guide/Interrupt_and_process_binding.html

Subsection:
Procedure 2.4. Excluding CPUs from IRQ Balancing

Starting on RHEL 7.2, when using the isolcpus= kernel parameter, and
the IRQBALANCE_BANNED_CPUS is not set on /etc/sysconfig/irqbalance config
file, the irqbalance will automatically avoid IRQs on CPUs isolated via
isolcpus=.

Please, add a note about this behavior in the section:
 - Procedure 2.4. Excluding CPUs from IRQ Balancing

For example:

"NOTE: The irqbalance will automatically avoid IRQs on CPUs isolated via
isolcpus= kernel parameter if IRQBALANCE_BANNED_CPUS is not set"
Comment 3 Radek Bíba 2015-08-06 09:37:49 EDT
Done in git, thanks for the heads up!

http://git.app.eng.bos.redhat.com/git/doc-Red_Hat_Enterprise_Linux-7-Realtime_Tuning_Guide.git/commit/?id=9e500b6422bafc10e0e4ce5778ade5131c99e4bd

(The note is outside the procedure block because (apparently) you can't use a note after you've started with steps.)

Note You need to log in before you can comment on or make changes to this bug.