Bug 1249171 - Traceback in horizon utility when installing all RPMs in the same transaction
Traceback in horizon utility when installing all RPMs in the same transaction
Status: CLOSED CANTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: z5
: 7.0 (Kilo)
Assigned To: Matthias Runge
Ido Ovadia
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-31 13:36 EDT by Lon Hohberger
Modified: 2016-04-08 04:19 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-08 04:19:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lon Hohberger 2015-07-31 13:36:17 EDT
Description of problem:

In some instances when installing nearly all of the RPMs for RHEL OSP 7 at the same time, the assets script in python-django-horizon throws a backtrace if certain parts of tuskar are not installed, causing an RPM warning:

Traceback (most recent call last):
 File "/usr/share/openstack-dashboard/openstack_dashboard/utils/settings.py", line 28, in import_submodules
 submodule = importlib.import_module(name)
 File "/usr/lib/python2.7/site-packages/django/utils/importlib.py", line 45, in import_module
 __import__(name)
 File "/usr/share/openstack-dashboard/openstack_dashboard/local/enabled/_50_tuskar.py", line 1, in <module>
 ImportError: No module named tuskar_ui
 Traceback (most recent call last):
 File "/usr/share/openstack-dashboard/manage.py", line 23, in <module>
 execute_from_command_line(sys.argv)
 File "/usr/lib/python2.7/site-packages/django/core/management/__init__.py", line 338, in execute_from_command_line
 utility.execute()
 File "/usr/lib/python2.7/site-packages/django/core/management/__init__.py", line 312, in execute
 django.setup()
 File "/usr/lib/python2.7/site-packages/django/__init__.py", line 18, in setup
 apps.populate(settings.INSTALLED_APPS)
 File "/usr/lib/python2.7/site-packages/django/apps/registry.py", line 85, in populate
 app_config = AppConfig.create(entry)
 File "/usr/lib/python2.7/site-packages/django/apps/config.py", line 86, in create
 module = import_module(entry)
 File "/usr/lib64/python2.7/importlib/__init__.py", line 37, in import_module
 __import__(name)


Version-Release number of selected component (if applicable):
  python-django-horizon.noarch 0:2015.1.0-10.el7ost                             


How reproducible: Rare, in real-world tests.

Steps to Reproduce:
1. rpm -Uvh (every rpm in RHEL OSP and RHEL OSP director at the same time)


Additional info:

This does not happen when using packstack or RHEL OSP director.  It has something to do with RPM ordering.

In this particular case, it happens when redhat-access-plugins-openstack calls this Horizon script.
Comment 4 Matthias Runge 2015-08-07 15:15:25 EDT
Hmm, I can not do much about tuskar-ui here. It looks like tuskar-ui was only half installed?
At least, horizon does not install tuskars config.

Can we try to reproduce this some more? Is it a installer issue?

To make sure, tuskar-ui is finally correctly installed, it should trigger httpd restart, too.
Comment 7 Matthias Runge 2016-04-08 04:19:26 EDT
Closing this, can't reproduce. Please re-open, when it happens again.

Note You need to log in before you can comment on or make changes to this bug.