Bug 1249370 - BX100 SSD with E3800 Series SATA AHCI Controller only gets UDMA133 performance
BX100 SSD with E3800 Series SATA AHCI Controller only gets UDMA133 performance
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-01 23:29 EDT by Steven Ellis
Modified: 2015-11-20 22:52 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-20 22:52:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Ellis 2015-08-01 23:29:01 EDT
Description of problem:
Acer  ES1-411 laptop with Crucial BX100 SSD

SSD is Sata 3.1, and hardware is SATA 2 capable, but kernel is only enabling 1.5 Gbps

Version-Release number of selected component (if applicable):
Kernel - 4.1.2-200.fc22.x86_64

How reproducible:
Consistent

Steps to Reproduce:
1. Boot Hardware
2. journalctl -a | grep -i SATA
3. smartctl -a /dev/sda | grep "SATA Version"

Actual results:

[root@AspireE14 ~]# journalctl -a | grep -i SATA
Aug 01 17:18:10 AspireE14 kernel: ahci 0000:00:13.0: AHCI 0001.0300 32 slots 2 ports 3 Gbps 0x1 impl SATA mode
Aug 01 17:18:10 AspireE14 kernel: ata1: SATA max UDMA/133 abar m2048@0x9081e000 port 0x9081e100 irq 261
Aug 01 17:18:10 AspireE14 kernel: ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 300)

[root@AspireE14 ~]# smartctl -a /dev/sda | grep "SATA Version"
SATA Version is:  SATA 3.1, 6.0 Gb/s (current: 1.5 Gb/s)

[root@AspireE14 ~]# lspci  | grep SATA
00:13.0 SATA controller: Intel Corporation Atom Processor E3800 Series SATA AHCI Controller (rev 0e)

Expected results:
E3800 chipset supports SATA2 so I'd expect 3.0 Gb/s

Additional info:

00:13.0 SATA controller: Intel Corporation Atom Processor E3800 Series SATA AHCI Controller (rev 0e) (prog-if 01 [AHCI 1.0])
        Subsystem: Acer Incorporated [ALI] Device 0934
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
        Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0
        Interrupt: pin A routed to IRQ 261
        Region 0: I/O ports at 2048 [size=8]
        Region 1: I/O ports at 205c [size=4]
        Region 2: I/O ports at 2040 [size=8]
        Region 3: I/O ports at 2058 [size=4]
        Region 4: I/O ports at 2020 [size=32]
        Region 5: Memory at 9081e000 (32-bit, non-prefetchable) [size=2K]
        Capabilities: [80] MSI: Enable+ Count=1/1 Maskable- 64bit-
                Address: fee0f00c  Data: 41d1
        Capabilities: [70] Power Management version 3
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot+,D3cold-)
                Status: D0 NoSoftRst+ PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [a8] SATA HBA v1.0 BAR4 Offset=00000004
        Kernel driver in use: ahci

AHCI details from boot

Aug 01 17:18:10 AspireE14 kernel: ahci 0000:00:13.0: version 3.0
Aug 01 17:18:10 AspireE14 kernel: ahci 0000:00:13.0: controller can't do DEVSLP, turning off
Aug 01 17:18:10 AspireE14 kernel: ahci 0000:00:13.0: AHCI 0001.0300 32 slots 2 ports 3 Gbps 0x1 impl SATA mode
Aug 01 17:18:10 AspireE14 kernel: ahci 0000:00:13.0: flags: 64bit ncq pm led clo pio slum part deso 
Aug 01 17:18:10 AspireE14 kernel: scsi host0: ahci
Aug 01 17:18:10 AspireE14 kernel: scsi host1: ahci
Aug 01 17:18:10 AspireE14 kernel: ata1: SATA max UDMA/133 abar m2048@0x9081e000 port 0x9081e100 irq 261
Aug 01 17:18:10 AspireE14 kernel: ata2: DUMMY
Comment 1 Steven Ellis 2015-08-01 23:47:20 EDT
Basic performance test under hdparm shows the issue

[root@AspireE14 ~]# hdparm  -t /dev/sda

/dev/sda:
 Timing buffered disk reads: 408 MB in  3.00 seconds = 135.80 MB/sec
Comment 2 Steven Ellis 2015-08-02 01:03:36 EDT
Tested laptop under RHEL7 and we get much better SSD performance as we're now running with SATA-2 rather than SATA-1

[root@localhost ~]# uname -a
Linux localhost.localdomain 3.10.0-229.7.2.el7.x86_64 #1 SMP Fri May 15 21:38:46 EDT 2015 x86_64 x86_64 x86_64 GNU/Linux


[root@localhost ~]# hdparm -t /dev/sda

/dev/sda:
 Timing buffered disk reads: 818 MB in  3.00 seconds = 272.53 MB/sec


[root@localhost ~]# journalctl | grep ahci
Aug 03 04:43:11 localhost.localdomain kernel: ahci 0000:00:13.0: version 3.0
Aug 03 04:43:11 localhost.localdomain kernel: ahci 0000:00:13.0: irq 105 for MSI/MSI-X
Aug 03 04:43:11 localhost.localdomain kernel: ahci 0000:00:13.0: AHCI 0001.0300 32 slots 2 ports 3 Gbps 0x1 impl SATA mode
Aug 03 04:43:11 localhost.localdomain kernel: ahci 0000:00:13.0: flags: 64bit ncq pm led clo pio slum part deso sadm sds 
Aug 03 04:43:11 localhost.localdomain kernel: scsi host0: ahci
Aug 03 04:43:11 localhost.localdomain kernel: scsi host1: ahci

[root@localhost ~]# journalctl | grep SATA
Aug 03 04:43:11 localhost.localdomain kernel: ahci 0000:00:13.0: AHCI 0001.0300 32 slots 2 ports 3 Gbps 0x1 impl SATA mode
Aug 03 04:43:11 localhost.localdomain kernel: ata1: SATA max UDMA/133 abar m2048@0x9081d000 port 0x9081d100 irq 105
Aug 03 04:43:12 localhost.localdomain kernel: ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)

[root@localhost ~]# smartctl -a /dev/sda | grep "SATA Ver"
SATA Version is:  SATA 3.1, 6.0 Gb/s (current: 3.0 Gb/s)
Comment 3 Justin M. Forbes 2015-10-20 15:18:15 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 22 kernel bugs.

Fedora 22 has now been rebased to 4.2.3-200.fc22.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 23, and are still experiencing this issue, please change the version to Fedora 23.

If you experience different issues, please open a new bug report for those.
Comment 4 Steven Ellis 2015-10-28 00:42:49 EDT
Upgraded kernel as requested. Still getting SATA 1 performance

[root@AspireE14 ~]# uname -a
Linux AspireE14 4.2.3-200.fc22.x86_64 #1 SMP Thu Oct 8 03:23:55 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
[root@AspireE14 ~]# smartctl -a /dev/sda | grep "SATA Ver"
SATA Version is:  SATA 3.1, 6.0 Gb/s (current: 1.5 Gb/s)
[root@AspireE14 ~]# hdparm -t /dev/sda

/dev/sda:
 Timing buffered disk reads: 408 MB in  3.00 seconds = 135.82 MB/sec
Comment 5 Steven Ellis 2015-10-28 02:54:03 EDT
Tested drive using Windows 10 and CrystalDiskMark and I'm getting SATA-2 performance. Issue isn't BIOS/UEFI or Hardware specific.

CrystalDiskInfo reports transfer mode as SATA 300 under Windows 10.
Comment 6 Steven Ellis 2015-11-04 22:22:53 EST
Since running Windows 10 performance now appears to be Sata2

Current kernel

[root@AspireE14 ~]# uname -a
Linux AspireE14 4.1.6-200.fc22.x86_64 #1 SMP Mon Aug 17 19:54:31 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

Simple DD test on a 1GB File

[root@AspireE14 ~]# echo 3 > /proc/sys/vm/drop_caches
[root@AspireE14 ~]# dd if=tempfile  of=/dev/null bs=1M count=1024 
1024+0 records in
1024+0 records out
1073741824 bytes (1.1 GB) copied, 3.82645 s, 281 MB/s

hdparm sanity test

[root@AspireE14 ~]# hdparm -t /dev/sda

/dev/sda:
 Timing buffered disk reads: 808 MB in  3.01 seconds = 268.83 MB/sec


Checking SATA version

[root@AspireE14 ~]# smartctl -a /dev/sda | grep "SATA Ver"
SATA Version is:  SATA 3.1, 6.0 Gb/s (current: 3.0 Gb/s)


I'll re-test when I next upgrade the kernel. Got secondary stability issues running kernel-4.2.3-200.fc22.x86_64
Comment 7 Steven Ellis 2015-11-20 22:52:59 EST
Re-tested with Fedora 23 and Kernel 4.2.6-300.fc23.x86_64

[root@AspireE14 ~]# hdparm -t /dev/sda

/dev/sda:
 Timing buffered disk reads: 802 MB in  3.00 seconds = 266.97 MB/sec
[root@AspireE14 ~]# smartctl -a /dev/sda | grep "SATA Ver"
SATA Version is:  SATA 3.1, 6.0 Gb/s (current: 3.0 Gb/s)
[root@AspireE14 ~]# uname -r
4.2.6-300.fc23.x86_64
[root@AspireE14 ~]# dd if=/dev/zero of=tempfile bs=1M count=1024 conv=fdatasync,notrunc
1024+0 records in
1024+0 records out
1073741824 bytes (1.1 GB) copied, 5.02495 s, 214 MB/s
[root@AspireE14 ~]# echo 3 > /proc/sys/vm/drop_caches
[root@AspireE14 ~]# dd if=tempfile  of=/dev/null bs=1M count=1024 
1024+0 records in
1024+0 records out
1073741824 bytes (1.1 GB) copied, 3.86415 s, 278 MB/s

Issue appears to be resolved

Note You need to log in before you can comment on or make changes to this bug.