Bug 1249392 - Rewriting Candlepin config redundantly tries to create its db in postgres
Rewriting Candlepin config redundantly tries to create its db in postgres
Status: CLOSED WORKSFORME
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer (Show other bugs)
6.0.8
x86_64 Linux
low Severity low (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-02 08:15 EDT by Pavel Moravec
Modified: 2016-08-25 13:00 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-25 13:00:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 1552293 None None None Never

  None (edit)
Description Pavel Moravec 2015-08-02 08:15:19 EDT
Description of problem:
Sequence of:
- katello-installer
- modifying candlepin.conf (i.e. enable debugs, whatever)
- katello-installer

fails with error:

 /Stage[main]/Candlepin::Database/Postgresql::Server::Db[candlepin]/Postgresql::Server::Database[candlepin]/Exec[/usr/bin/createdb --port='5432' --owner='postgres' --template=template0  'candlepin']: Failed to call refresh: /usr/bin/createdb --port='5432' --owner='postgres' --template=template0  'candlepin' returned 1 instead of one of [0]


I assume the createdb of candlepin db is triggered by puppet that realized /etc/candlepin/candlepin.conf needs to be updated (as file has been changed). This dependency "fix config => createdb" sounds redundant - can't it even reset/break something? What else redundantly depends on the "fix config" step?
 

Version-Release number of selected component (if applicable):
katello-installer-0.0.67-1.el6sat.noarch
(noticed in Sat6.0.8, expected on 6.1beta as well)


How reproducible:
100%


Steps to Reproduce:
On a fresh machine:

katello-installer
echo >> /etc/candlepin/candlepin.conf
katello-installer


Actual results:
2nd installer fails with:

 /Stage[main]/Candlepin::Database/Postgresql::Server::Db[candlepin]/Postgresql::Server::Database[candlepin]/Exec[/usr/bin/createdb --port='5432' --owner='postgres' --template=template0  'candlepin']: Failed to call refresh: /usr/bin/createdb --port='5432' --owner='postgres' --template=template0  'candlepin' returned 1 instead of one of [0]
 /Stage[main]/Candlepin::Database/Postgresql::Server::Db[candlepin]/Postgresql::Server::Database[candlepin]/Exec[/usr/bin/createdb --port='5432' --owner='postgres' --template=template0  'candlepin']: /usr/bin/createdb --port='5432' --owner='postgres' --template=template0  'candlepin' returned 1 instead of one of [0]


Expected results:
no error

Additional info:
Comment 2 Bryan Kearney 2016-07-26 11:25:24 EDT
Moving 6.2 bugs out to sat-backlog.
Comment 3 Bryan Kearney 2016-07-26 11:42:09 EDT
Moving 6.2 bugs out to sat-backlog.
Comment 5 Stephen Benjamin 2016-08-25 13:00:13 EDT
Seems to be fixed on Satellite 6.2 GA.

Note You need to log in before you can comment on or make changes to this bug.