Bug 1249395 - AUTHORS is missed in tarball
AUTHORS is missed in tarball
Status: CLOSED CURRENTRELEASE
Product: rpmgrill
Classification: Community
Component: Infrastructure (Show other bugs)
0.23
Unspecified Unspecified
high Severity high
: ---
: 0.30
Assigned To: cqi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-02 08:52 EDT by cqi
Modified: 2017-01-22 19:48 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-22 19:48:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description cqi 2015-08-02 08:52:20 EDT
Description of problem:
AUTHORS does not exist in the tarball, that causes building RPM package fails.

Version-Release number of selected component (if applicable):


How reproducible:
100%


Actual results:
failure happens when handle %files section, logs here

... (ignore previous lines generated by rpmbuild)
+ /usr/bin/mkdir -p /builddir/build/BUILDROOT/rpmgrill-0.28-1.fc21.x86_64/usr/share/doc/rpmgrill
+ cp -pr README.AAA_FIRST /builddir/build/BUILDROOT/rpmgrill-0.28-1.fc21.x86_64/usr/share/doc/rpmgrill
+ cp -pr LICENSE /builddir/build/BUILDROOT/rpmgrill-0.28-1.fc21.x86_64/usr/share/doc/rpmgrill
+ cp -pr AUTHORS /builddir/build/BUILDROOT/rpmgrill-0.28-1.fc21.x86_64/usr/share/doc/rpmgrill
cp: cannot stat 'AUTHORS': No such file or directory
error: Bad exit status from /var/tmp/rpm-tmp.2UnLiE (%doc)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.2UnLiE (%doc)
ERROR: Exception(/project/rpmgrill-0.28-1.fc19.src.rpm) Config(fedora-21-x86_64) 0 minutes 28 seconds
INFO: Results and/or logs in: /var/lib/mock/fedora-21-x86_64/result
ERROR: Command failed. See logs for output.

Expected results:
AUTHORS is put into the tarball

Additional info:
Comment 1 yashi 2015-08-07 05:30:34 EDT
how did you get your src rpm file, here is my testing, works,

[larry@dhcp-140-104 rpmgrill]$ make srpm 
perl Build.PL
Created MYMETA.yml and MYMETA.json
Creating new 'Build' script for 'rpmgrill' version '0.0'
./Build distdir
Created META.yml and META.json
Creating rpmgrill-0.0
test -d rpmgrill-0.0 || exit 1
find rpmgrill-0.0 -type f | xargs perl -pi -e "s/VERSION\s+=\s+'.*?';/VERSION = '0.28';/"
rm -f rpmgrill-0.0/doc/tooltips.txt
perl -Ilib bin/make-tooltips >| rpmgrill-0.0/doc/tooltips.txt
mv rpmgrill-0.0 rpmgrill-0.28
tar cjf rpmgrill-0.28.tar.bz2 rpmgrill-0.28
rm -rf rpmgrill-0.28
rpmbuild -bs --nodeps --define "_sourcedir ." --define "_srcrpmdir ." --define "dist .fc19" rpmgrill.spec
Wrote: ./rpmgrill-0.28-1.fc19.src.rpm


tips

[larry@dhcp-140-104 rpmgrill]$ pwd
/home/larry/pnt/dev/rpmgrill
[larry@dhcp-140-104 rpmgrill]$ uname -a
Linux dhcp-140-104.nay.redhat.com 4.1.2-200.fc22.x86_64 #1 SMP Wed Jul 15 20:12:12 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
[larry@dhcp-140-104 rpmgrill]$ git remote show origin
* remote origin
  Fetch URL: https://github.com/larry-shi/rpmgrill.git
  Push  URL: https://github.com/larry-shi/rpmgrill.git


anything wrong with me?
Comment 2 cqi 2015-08-07 05:51:50 EDT
(In reply to yashi from comment #1)
> how did you get your src rpm file, here is my testing, works,
> 

This bug happens when build a binary RPM package.
Comment 3 yashi 2015-08-09 21:25:22 EDT
(In reply to cqi from comment #2)
> (In reply to yashi from comment #1)
> > how did you get your src rpm file, here is my testing, works,
> > 
> 
> This bug happens when build a binary RPM package.

thanks
Comment 4 yashi 2015-08-09 22:36:00 EDT
deep into https://kojipkgs.fedoraproject.org//packages/rpmgrill/0.28/1.fc22/noarch/rpmgrill-0.28-1.fc22.noarch.rpm

find the reason is because  AUTHORS file (./usr/share/doc/rpmgrill/AUTHORS) is not committed into our source tree.
Comment 5 cqi 2015-08-09 22:53:26 EDT
(In reply to yashi from comment #4)
> deep into
> https://kojipkgs.fedoraproject.org//packages/rpmgrill/0.28/1.fc22/noarch/
> rpmgrill-0.28-1.fc22.noarch.rpm
> 
> find the reason is because  AUTHORS file (./usr/share/doc/rpmgrill/AUTHORS)
> is not committed into our source tree.

No.

  %doc AUTHORS

this line in %files results in the existence of ./usr/share/doc/rpmgrill/AUTHORS

Refer to http://fedoraproject.org/wiki/How_to_create_an_RPM_package#.25files_prefixes
Comment 6 Roman Joost 2017-01-22 19:48:02 EST
This has been released with rpmgrill-0.30.

Note You need to log in before you can comment on or make changes to this bug.