Bug 1249411 - [abrt] lyx: lyx::error_handler(): lyx killed by SIGABRT
[abrt] lyx: lyx::error_handler(): lyx killed by SIGABRT
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lyx (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:d3798b8e567281d33599b8e77ed...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-02 11:50 EDT by Felix Kaechele
Modified: 2016-06-18 14:54 EDT (History)
3 users (show)

See Also:
Fixed In Version: lyx-2.2.0-1.fc23 lyx-2.2.0-1.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-07 21:24:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (26.13 KB, text/plain)
2015-08-02 11:50 EDT, Felix Kaechele
no flags Details
File: cgroup (190 bytes, text/plain)
2015-08-02 11:50 EDT, Felix Kaechele
no flags Details
File: core_backtrace (3.49 KB, text/plain)
2015-08-02 11:50 EDT, Felix Kaechele
no flags Details
File: dso_list (13.84 KB, text/plain)
2015-08-02 11:50 EDT, Felix Kaechele
no flags Details
File: environ (1004 bytes, text/plain)
2015-08-02 11:50 EDT, Felix Kaechele
no flags Details
File: limits (1.29 KB, text/plain)
2015-08-02 11:50 EDT, Felix Kaechele
no flags Details
File: maps (65.56 KB, text/plain)
2015-08-02 11:50 EDT, Felix Kaechele
no flags Details
File: mountinfo (3.57 KB, text/plain)
2015-08-02 11:50 EDT, Felix Kaechele
no flags Details
File: namespaces (85 bytes, text/plain)
2015-08-02 11:50 EDT, Felix Kaechele
no flags Details
File: open_fds (744 bytes, text/plain)
2015-08-02 11:50 EDT, Felix Kaechele
no flags Details
File: proc_pid_status (1003 bytes, text/plain)
2015-08-02 11:50 EDT, Felix Kaechele
no flags Details
File: var_log_messages (225 bytes, text/plain)
2015-08-02 11:51 EDT, Felix Kaechele
no flags Details

  None (edit)
Description Felix Kaechele 2015-08-02 11:50:36 EDT
Description of problem:
LyX crashed while opening a document from nautilus.

Version-Release number of selected component:
lyx-2.1.3-1.fc22

Additional info:
reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        lyx '/home/sarah/Dropbox/Bachelorarbeit/schriftliche Ausarbeitung/Bachelorarbeit.lyx'
crash_function: lyx::error_handler
executable:     /usr/bin/lyx
global_pid:     9666
kernel:         4.1.3-200.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 lyx::error_handler at LyX.cpp:696
 #4 ??
 #5 QFactoryLoader::instance at plugin/qfactoryloader.cpp:276
 #6 QIcon::addFile at image/qicon.cpp:843
 #7 QIcon::QIcon at image/qicon.cpp:565
 #8 ScalableEntry::pixmap at image/qiconloader.cpp:515
 #9 QIconLoaderEngine::pixmap at image/qiconloader.cpp:528
 #10 QIcon::pixmap at image/qicon.cpp:684
 #11 QWidgetPrivate::setWindowIcon_sys at kernel/qwidget_x11.cpp:1490
 #12 QWidget::create at kernel/qwidget.cpp:1534

Potential duplicate: bug 1098464
Comment 1 Felix Kaechele 2015-08-02 11:50:42 EDT
Created attachment 1058559 [details]
File: backtrace
Comment 2 Felix Kaechele 2015-08-02 11:50:46 EDT
Created attachment 1058560 [details]
File: cgroup
Comment 3 Felix Kaechele 2015-08-02 11:50:48 EDT
Created attachment 1058561 [details]
File: core_backtrace
Comment 4 Felix Kaechele 2015-08-02 11:50:49 EDT
Created attachment 1058562 [details]
File: dso_list
Comment 5 Felix Kaechele 2015-08-02 11:50:50 EDT
Created attachment 1058563 [details]
File: environ
Comment 6 Felix Kaechele 2015-08-02 11:50:52 EDT
Created attachment 1058564 [details]
File: limits
Comment 7 Felix Kaechele 2015-08-02 11:50:54 EDT
Created attachment 1058565 [details]
File: maps
Comment 8 Felix Kaechele 2015-08-02 11:50:55 EDT
Created attachment 1058566 [details]
File: mountinfo
Comment 9 Felix Kaechele 2015-08-02 11:50:56 EDT
Created attachment 1058567 [details]
File: namespaces
Comment 10 Felix Kaechele 2015-08-02 11:50:57 EDT
Created attachment 1058568 [details]
File: open_fds
Comment 11 Felix Kaechele 2015-08-02 11:50:58 EDT
Created attachment 1058569 [details]
File: proc_pid_status
Comment 12 Felix Kaechele 2015-08-02 11:51:00 EDT
Created attachment 1058570 [details]
File: var_log_messages
Comment 13 José Matos 2015-08-15 09:34:26 EDT
Thank you for the report.

I will report this to the lyx developers mailing list, meanwhile 2.1.4 is already available as an update and I remeber that some bugs like have been fixed.

Please update to the latest stable release and tell us if the problem persists.
Comment 14 Robert Susmilch 2016-02-07 17:21:18 EST
Similar problem has been detected:

Created a sub-table. Within the actual tabular environment I deleted the current top-most row using the icons at the bottom of LyX. I then pressed Control-Z to undo my mistaken row deletion, which is when LyX crashed.

reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        /usr/bin/lyx
crash_function: lyx::error_handler
executable:     /usr/bin/lyx
global_pid:     1976
kernel:         4.3.4-200.fc22.x86_64
package:        lyx-2.1.4-1.fc22
reason:         lyx killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 15 José Matos 2016-02-15 06:27:50 EST
(In reply to Robert Susmilch from comment #14)
> Similar problem has been detected:
> 
> Created a sub-table. Within the actual tabular environment I deleted the
> current top-most row using the icons at the bottom of LyX. I then pressed
> Control-Z to undo my mistaken row deletion, which is when LyX crashed.

The bug that you refer seems to be related with a bad interaction between table and undo components and that seems completely unrelated to this bug. :-)

Do you have further information about this bug?
Did you get a crash after when using tables and undoing an action?

I do not remember other reports about this issue. Note I am not saying that there are not any just that I do not remember seeing them. :-)
Comment 16 Fedora Update System 2016-05-30 12:21:30 EDT
lyx-2.2.0-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-c5a1e5369a
Comment 17 Fedora Update System 2016-05-30 13:48:09 EDT
lyx-2.2.0-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-782ef161fa
Comment 18 Fedora Update System 2016-05-30 23:53:33 EDT
lyx-2.2.0-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-c5a1e5369a
Comment 19 Fedora Update System 2016-05-31 05:52:00 EDT
lyx-2.2.0-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-782ef161fa
Comment 20 Fedora Update System 2016-06-07 21:24:22 EDT
lyx-2.2.0-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 21 Fedora Update System 2016-06-18 14:54:29 EDT
lyx-2.2.0-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.