Bug 1249440 - systemd-detect-virt does not identify rhev/ovirt
systemd-detect-virt does not identify rhev/ovirt
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemd (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: systemd-maint
qe-baseos-daemons
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-02 21:52 EDT by Ryan Barry
Modified: 2016-11-11 02:53 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-11 02:53:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan Barry 2015-08-02 21:52:11 EDT
Description of problem:
systemd-detect-virt reports ovirt/rhev guests as "kvm" instead of 'ovirt' or 'rhev'

Version-Release number of selected component (if applicable):
systemd-208-20.el7_1.5.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Run systemd-detect-virt in a rhev/ovirt guest
2.
3.

Actual results:
kvm

Expected results:
ovirt (or rhev, as appropriate)

Additional info:
This can be checked in dmidecode:
Manufacturer: oVirt
Product Name: oVirt Node

Product Name: RHEV Hypervisor

(it's also oVirt Node/RHEV Hypervisor for the guests)
Comment 2 Lukáš Nykrýn 2015-08-03 07:31:16 EDT
RHEV/ovirt is just a name of a product, underlying virtualization technology is KVM.
Comment 3 Ryan Barry 2015-08-03 10:23:44 EDT
The idea behind filing this bug is that configuration management systems (including puppet) currently detect whether systems are running on ovirt/rhev, regardless of what the underlying technology is. It allows fingerprinting systems to add them to host groups more easily.

virt-what currently has the same bug, meaning that puppet (as an example) correctly detects ovirt/rhev if facter is run as a non-root user, but detects kvm if virt-what is used. salt already uses systemd-detect-virt where available.

On these platforms, ovirt/rhev guests will not be identified, and this is not a bug in salt or anything else using systemd-detect-virt. 

This detecting (via dmi for a kvm guest) appears to already be done for oracle. Adding ovirt/rhev is very easy, matches the existing pattern, and has advantages for users of systemd-detect-virt
Comment 4 Michal Sekletar 2015-08-03 15:59:42 EDT
(In reply to Ryan Barry from comment #3)

> This detecting (via dmi for a kvm guest) appears to already be done for
> oracle. Adding ovirt/rhev is very easy, matches the existing pattern, and
> has advantages for users of systemd-detect-virt

It seems to me that comparison with oracle case is only partially applicable to this bug. Oracle Virtualbox is standalone virtualization technology which recently got ability to use KVM instead as a back-end. However ovirt is only management layer. Those two are very different situations, because in former case all units which had ConditionVirtualization=oracle would not start in case you use Virtualbox with KVM.

I think this deserves discussion upstream. Can you please open issue on GitHub about this?
Comment 5 Jan Synacek 2016-11-11 02:53:57 EST
No response for over a year. Plus, comment 2.

Note You need to log in before you can comment on or make changes to this bug.