Bug 1249539 - [abrt] blueman: connection.py:651:call_blocking:DBusException: org.freedesktop.DBus.Error.AccessDenied: Rejected send message, 2 matched rules; type="method_call", sender=":1.96" (uid=1000 pid=1022 comm="python /bin/blueman-applet ") interface="org.fre...
[abrt] blueman: connection.py:651:call_blocking:DBusException: org.freedeskto...
Status: CLOSED DUPLICATE of bug 1249540
Product: Fedora
Classification: Fedora
Component: blueman (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: leigh scott
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:887c509c484b5754138206418fa...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-03 05:33 EDT by Antonio Guzmán Simón
Modified: 2015-08-03 05:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-03 05:43:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (2.76 KB, text/plain)
2015-08-03 05:33 EDT, Antonio Guzmán Simón
no flags Details
File: environ (1.14 KB, text/plain)
2015-08-03 05:34 EDT, Antonio Guzmán Simón
no flags Details

  None (edit)
Description Antonio Guzmán Simón 2015-08-03 05:33:56 EDT
Version-Release number of selected component:
blueman-2.0-11.fc22

Additional info:
reporter:       libreport-2.6.2
cmdline:        python /bin/blueman-applet
dso_list:       dbus-python-1.2.0-7.fc22.x86_64
executable:     /bin/blueman-applet
kernel:         4.1.2-200.fc22.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
connection.py:651:call_blocking:DBusException: org.freedesktop.DBus.Error.AccessDenied: Rejected send message, 2 matched rules; type="method_call", sender=":1.96" (uid=1000 pid=1022 comm="python /bin/blueman-applet ") interface="org.freedesktop.DBus.Introspectable" member="Introspect" error name="(unset)" requested_reply="0" destination=":1.34" (uid=0 pid=1661 comm="/usr/libexec/bluetooth/bluetoothd ")

Traceback (most recent call last):
  File "/bin/blueman-applet", line 121, in <module>
    BluemanApplet()
  File "/bin/blueman-applet", line 63, in __init__
    self.Plugins.Load()
  File "/usr/lib/python2.7/site-packages/blueman/main/PluginManager.py", line 90, in Load
    __import__(self.module_path.__name__ + ".%s" % plugin, None, None, [])
  File "/usr/lib/python2.7/site-packages/blueman/plugins/applet/AuthAgent.py", line 9, in <module>
    import blueman.main.applet.BluezAgent as BluezAgent
  File "/usr/lib/python2.7/site-packages/blueman/main/applet/BluezAgent.py", line 20, in <module>
    from blueman.bluez.Agent import Agent, AgentMethod
  File "/usr/lib/python2.7/site-packages/blueman/bluez/Agent.py", line 48, in <module>
    class Agent(dbus.service.Object):
  File "/usr/lib/python2.7/site-packages/blueman/bluez/Agent.py", line 56, in Agent
    @AgentMethod
  File "/usr/lib/python2.7/site-packages/blueman/bluez/Agent.py", line 38, in AgentMethod
    if BlueZInterface.get_interface_version()[0] < 5:
  File "/usr/lib/python2.7/site-packages/blueman/bluez/BlueZInterface.py", line 17, in get_interface_version
    introspection = dbus.Interface(obj, 'org.freedesktop.DBus.Introspectable').Introspect()
  File "/usr/lib64/python2.7/site-packages/dbus/proxies.py", line 70, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib64/python2.7/site-packages/dbus/proxies.py", line 145, in __call__
    **keywords)
  File "/usr/lib64/python2.7/site-packages/dbus/connection.py", line 651, in call_blocking
    message, timeout)
DBusException: org.freedesktop.DBus.Error.AccessDenied: Rejected send message, 2 matched rules; type="method_call", sender=":1.96" (uid=1000 pid=1022 comm="python /bin/blueman-applet ") interface="org.freedesktop.DBus.Introspectable" member="Introspect" error name="(unset)" requested_reply="0" destination=":1.34" (uid=0 pid=1661 comm="/usr/libexec/bluetooth/bluetoothd ")

Local variables in innermost frame:
byte_arrays: False
self: <dbus._dbus.SystemBus (system) at 0x7f7478040b90>
args: ()
object_path: u'/'
signature: None
bus_name: dbus.UTF8String(':1.34')
get_args_opts: {'byte_arrays': False, 'utf8_strings': False}
timeout: -1.0
kwargs: {}
dbus_interface: u'org.freedesktop.DBus.Introspectable'
message: <dbus.lowlevel.MethodCallMessage path: /, iface: org.freedesktop.DBus.Introspectable, member: Introspect dest: :1.34>
method: 'Introspect'
Comment 1 Antonio Guzmán Simón 2015-08-03 05:33:59 EDT
Created attachment 1058700 [details]
File: backtrace
Comment 2 Antonio Guzmán Simón 2015-08-03 05:34:00 EDT
Created attachment 1058701 [details]
File: environ
Comment 3 leigh scott 2015-08-03 05:43:26 EDT

*** This bug has been marked as a duplicate of bug 1249540 ***

Note You need to log in before you can comment on or make changes to this bug.