Bug 1249597 - “dnf grouplist” doesn’t work (Python backtrace)
“dnf grouplist” doesn’t work (Python backtrace)
Status: CLOSED DUPLICATE of bug 1245872
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-03 07:30 EDT by Mike FABIAN
Modified: 2015-08-03 08:48 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-03 08:48:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike FABIAN 2015-08-03 07:30:45 EDT
Fedora 23 Alpha TC2
(Fedora-Workstation-netinst-x86_64-23_Alpha_TC2.iso) installed in qemu
with:

nice ionice -c 3 qemu-kvm -machine pc-1.3 -enable-kvm -global qxl.ram_size=1x1024 -m 2048M -smp 2 -drive file=./Fedora-Workstation-netinst-x86_64-23_Alpha_TC2.iso.qcow2,index=0,media=disk,cache=unsafe -localtime -serial file:/tmp/qemu-Fedora-Workstation-netinst-x86_64-23_Alpha_TC2.iso.qcow2-output.log -name Fedora-Workstation-netinst-x86_64-23_Alpha_TC2.iso.qcow2 -cdrom /local/mfabian/iso/Fedora-23-Alpha-TC2/Fedora-Workstation-netinst-x86_64-23_Alpha_TC2.iso -boot c -spice port=6002,disable-ticketing,streaming-video=off -vga qxl -display vnc=:6 -net nic -net user,hostname=Fedora-Workstation-netinst-x86_64-23_Alpha_TC2.iso.qcow2,hostfwd=tcp::5562-:22 -monitor stdio -usb

After the installation:

[mfabian@Fedora-Workstation-netinst-x86_6 ~]$ dnf group list 
Last metadata expiration check performed 0:00:50 ago on Mon Aug  3 13:22:38 2015.
Traceback (most recent call last):
  File "/usr/bin/dnf", line 35, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 190, in user_main
    errcode = main(args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 84, in main
    return _main(base, args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 139, in _main
    cli.run()
  File "/usr/lib/python3.4/site-packages/dnf/cli/cli.py", line 1076, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python3.4/site-packages/dnf/cli/commands/group.py", line 383, in run
    return self._list(extcmds)
  File "/usr/lib/python3.4/site-packages/dnf/cli/commands/group.py", line 167, in _list
    for group in userlist:
TypeError: 'NoneType' object is not iterable
[mfabian@Fedora-Workstation-netinst-x86_6 ~]$

On Fedora 22, this works.
Comment 1 Michal Luscon 2015-08-03 08:48:45 EDT

*** This bug has been marked as a duplicate of bug 1245872 ***

Note You need to log in before you can comment on or make changes to this bug.