Bug 1249619 - Failed to stop stack error from functional tests with engine_workers=2
Failed to stop stack error from functional tests with engine_workers=2
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-heat (Show other bugs)
6.0 (Juno)
All Linux
high Severity medium
: async
: 6.0 (Juno)
Assigned To: Zane Bitter
Amit Ugol
: Triaged, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-03 08:21 EDT by Pratik Pravin Bandarkar
Modified: 2016-04-26 16:14 EDT (History)
6 users (show)

See Also:
Fixed In Version: openstack-heat-2014.2.3-6.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-08 09:08:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pratik Pravin Bandarkar 2015-08-03 08:21:39 EDT
Description of problem:
After trying to enable 2 engine workers in the stack we got an error:
"ERROR: Failed to stop stack (StackValidationTest-2106167672) on other engine (c37574aa-99c2-4e94-bc12-ae576a531db7)

Note in the engine logs:
"
oslo_messaging.rpc.dispatcher [-] Expected exception during message handling (Failed to stop stack (StackValidationTest-2106167672) on other engine (c37574aa-99c2-4e94-bc12-ae576a531db7)) _dispatch_and_reply /usr/local/lib/python2.7/dist-packages/oslo_messaging/rpc/dispatcher.py:145"

Issue is fixed in kilo, need to backport the fix in juno:

https://bugs.launchpad.net/heat/+bug/1433821

https://review.openstack.org/#/c/165712/

https://git.openstack.org/cgit/openstack/heat/commit/?id=f19c54dd9a906a538b527268b6746daa162da5ad

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 5 Steven Hardy 2015-09-01 13:26:29 EDT
Upstream backport to Juno has landed:

https://review.openstack.org/#/c/210606/
Comment 9 Amit Ugol 2015-10-06 14:16:56 EDT
I played with 2+ engines and calling delete rapidly and was unable to reproduce.
Tested with 2014.2.3-6.el7ost
Comment 11 errata-xmlrpc 2015-10-08 09:08:22 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1877.html

Note You need to log in before you can comment on or make changes to this bug.