Bug 124985 - enable safe mode overriding safe_mode option
Summary: enable safe mode overriding safe_mode option
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: php   
(Show other bugs)
Version: 2
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-01 19:40 UTC by Andrew Nagy
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-02 15:15:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
PHP INI file (37.55 KB, text/plain)
2004-06-01 20:24 UTC, Andrew Nagy
no flags Details

Description Andrew Nagy 2004-06-01 19:40:08 UTC
Description of problem:

the default configuration has --enable-safe_mode and the default
php.ini has safe_mode = 0 which is hypocritical.  The problem is that
the "--enable-safe-mode" overrides the safe_mode option in the php.ini
and there is no way to turn off safe mode.

I also did not test this with the default php that comes with the
install, I am using the new php update via yum.

Comment 1 Joe Orton 2004-06-01 20:10:01 UTC
I can't reproduce this; the configure default is supposed to be
overridden by the /etc/php.ini setting.  Can you attach your
/etc/php.ini and a script which fails?

php-4.3.6-5

Comment 2 Andrew Nagy 2004-06-01 20:24:08 UTC
Created attachment 100762 [details]
PHP INI file

Comment 3 Andrew Nagy 2004-06-01 20:24:31 UTC
I didn't make any changes to the php.ini, I am using the default.

the error was on:
require_once('PEAR.php');

I managed to fix it by changing the owner of everything in the
/usr/share/pear directory to be owned by my group instead of by the
root group.

Since the php.ini has safe_mode = Off, why would I see any safe mode
errors at all?

Oh ... I did change the php.ini to show all errors.

Comment 4 Joe Orton 2004-06-01 20:32:19 UTC
Still can't reproduce with php-4.3.6-5.  php.ini should be setting
safe_mode to Off by default, and is for me.  What does:

# echo '<? phpinfo() ?>' | php -q  | grep safe_mode

give for you, also:

# rpm -q php

Comment 5 Andrew Nagy 2004-06-02 15:15:55 UTC
I can't duplicate it anymore.  It seems it must have been a
permissions issue.  The thing that I couldn't figure out is why I was
getting Safe Mode warnings when safe_mode option was off.  Very strange.


Note You need to log in before you can comment on or make changes to this bug.