Bug 1249923 - receive 500 internal error when extending the watchdog for an already finished recipe
receive 500 internal error when extending the watchdog for an already finish...
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: general (Show other bugs)
21
Unspecified Unspecified
unspecified Severity unspecified (vote)
: 21.0
: ---
Assigned To: matt jia
tools-bugs
: NeedsTestCase, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-04 03:25 EDT by matt jia
Modified: 2015-08-26 02:17 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-26 02:17:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description matt jia 2015-08-04 03:25:11 EDT
Description of problem:

When extending the watchdog for an already finished recipe by using bkr watchdog-extend, it will return 500 internal error on rhel6

How reproducible:

always
Steps to Reproduce:
1. bkr watchdog-extend <finished recipe>


Actual results:

bkr watchdog-extend returns 500 internal error

Expected results:

bkr watchdog-extend should return http 400 error
Comment 1 matt jia 2015-08-04 03:26:33 EDT
On Gerrit:

  http://gerrit.beaker-project.org/#/c/4329/1
Comment 2 Dan Callaghan 2015-08-05 00:08:17 EDT
I think this is just a regression on develop due to bug 1103582, right? Doesn't affect any released version of bkr watchdog-extend.
Comment 3 matt jia 2015-08-05 00:19:08 EDT
(In reply to Dan Callaghan from comment #2)
> I think this is just a regression on develop due to bug 1103582, right?
> Doesn't affect any released version of bkr watchdog-extend.

Indeed.
Comment 6 Dan Callaghan 2015-08-26 02:17:30 EDT
Beaker 21.0 has been released.

Note You need to log in before you can comment on or make changes to this bug.