Bug 1249976 - Fix uxa-damage.c:947:5: error: implicit declaration of function 'QueryGlyphExtents'
Fix uxa-damage.c:947:5: error: implicit declaration of function 'QueryGlyphEx...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-qxl (Show other bugs)
rawhide
All Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Alon Levy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-04 05:41 EDT by poma
Modified: 2015-08-06 14:35 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-05 17:04:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Update to git & fix implicit declaration of function (15.41 KB, patch)
2015-08-04 05:41 EDT, poma
no flags Details | Diff

  None (edit)
Description poma 2015-08-04 05:41:12 EDT
Created attachment 1058994 [details]
Update to git & fix implicit declaration of function

https://kojipkgs.fedoraproject.org/work/tasks/7640/10517640/build.log
...
uxa-damage.c:947:5: error: implicit declaration of function 'QueryGlyphExtents' [-Werror=implicit-function-declaration]
     QueryGlyphExtents(font, charinfo, n, &extents);
     ^

Resolution:
declare the function before it's used.

BTW this also affect the Rawhide lives not to build tutto completo
http://koji.fedoraproject.org/koji/tasks?state=all&view=tree&method=livecd&order=-id

BTW2 your proposed patch "xfont.patch",
see http://lists.freedesktop.org/archives/spice-devel/2015-August/021185.html
produces:
[    14.150] (EE) 
[    14.150] (EE) Backtrace:
[    14.150] (EE) 0: /usr/libexec/Xorg (OsLookupColor+0x139) [0x598cf9]
[    14.151] (EE) 1: /lib64/libc.so.6 (__restore_rt+0x0) [0x7fa4f7794c3f]
[    14.151] (EE) 2: /usr/lib64/xorg/modules/drivers/qxl_drv.so (_init+0x13657) [0x7fa4f24faa17]
[    14.151] (EE) 3: /usr/lib64/xorg/modules/drivers/qxl_drv.so (_init+0x105b1) [0x7fa4f24f4971]
[    14.151] (EE) 4: /usr/lib64/xorg/modules/drivers/qxl_drv.so (_init+0xd55c) [0x7fa4f24ee7fc]
[    14.151] (EE) 5: /usr/libexec/Xorg (remove_fs_handlers+0x326) [0x43a566]
[    14.168] (EE) 6: /lib64/libc.so.6 (__libc_start_main+0xf0) [0x7fa4f777f6c0]
[    14.168] (EE) 7: /usr/libexec/Xorg (_start+0x29) [0x424b09]
[    14.168] (EE) 8: ? (?+0x29) [0x29]
[    14.168] (EE) 
[    14.168] (EE) Segmentation fault at address 0x0
[    14.169] (EE) 
Fatal server error:
[    14.169] (EE) Caught signal 11 (Segmentation fault). Server aborting
[    14.169] (EE) 
[    14.169] (EE) 
Please consult the Fedora Project support 
	 at http://wiki.x.org
 for help. 
[    14.169] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    14.169] (EE) 
[    14.217] (EE) Server terminated with error (1). Closing log file.
Comment 1 poma 2015-08-04 05:42:52 EDT
Comment on attachment 1058994 [details]
Update to git & fix implicit declaration of function

- update to git commit e765cc5 2015-06-22
- fix uxa-damage.c:947:5: error: implicit declaration of function 'QueryGlyphExtents'
- xorg-server 1.18 ABI build
Comment 2 Christophe Fergeau 2015-08-04 11:21:31 EDT
Thanks for the patch and the testing! Not sure why I included some unneeded uxa-glyphs.c changes in my previous patches, good that you noticed it ;)

Couple of comments
- Why update to latest git master? I don't think this is required to fix that build failure, is it?
- Let's fix this upstream and then in rawhide
Comment 4 poma 2015-08-04 20:17:36 EDT
(In reply to Christophe Fergeau from comment #2)
> Thanks for the patch and the testing! Not sure why I included some unneeded
> uxa-glyphs.c changes in my previous patches, good that you noticed it ;)
> 
> Couple of comments
> - Why update to latest git master? I don't think this is required to fix
> that build failure, is it?

Ask yourself the question, why do upgrade in the first place.
I'm showing you what I use, for a reason, and what you will do is up to you.

> - Let's fix this upstream and then in rawhide

Happy campers already took for granted your original/broken patch,
so there is already a broken DDX in Rawhide
http://koji.fedoraproject.org/koji/buildinfo?buildID=673175
Changelog 	* Tue Aug 04 2015 Adam Williamson <awilliam@redhat.com> - 0.1.4-4
- fix build with a couple of patches from upstream list (from davidshea)
Comment 5 Christophe Fergeau 2015-08-05 05:32:08 EDT
(In reply to poma from comment #4)
> (In reply to Christophe Fergeau from comment #2)
> > Couple of comments
> > - Why update to latest git master? I don't think this is required to fix
> > that build failure, is it?
> 
> Ask yourself the question, why do upgrade in the first place.
> I'm showing you what I use, for a reason, and what you will do is up to you.

There are various reasons for that, critical bug fixes, new features, or just because there are improvements that can't hurt. I'm not running a rawhide system, so if upgrading to latest git is fixing important bugs in rawhide, I would not know. Since you had a need for these patches, I'm checking if there are bad bugs they fix, in which case they would be needed in rawhide.
Comment 6 Christophe Fergeau 2015-08-05 06:12:30 EDT
(In reply to poma from comment #4)
> http://koji.fedoraproject.org/koji/buildinfo?buildID=673175
> Changelog 	* Tue Aug 04 2015 Adam Williamson <awilliam@redhat.com> - 0.1.4-4
> - fix build with a couple of patches from upstream list (from davidshea)

Ah this is bug #1250214
Comment 7 poma 2015-08-05 08:55:26 EDT
(In reply to Christophe Fergeau from comment #5)
> (In reply to poma from comment #4)
> > (In reply to Christophe Fergeau from comment #2)
> > > Couple of comments
> > > - Why update to latest git master? I don't think this is required to fix
> > > that build failure, is it?
> > 
> > Ask yourself the question, why do upgrade in the first place.
> > I'm showing you what I use, for a reason, and what you will do is up to you.
> 
> There are various reasons for that, critical bug fixes, new features, or
> just because there are improvements that can't hurt. I'm not running a
> rawhide system, so if upgrading to latest git is fixing important bugs in
> rawhide, I would not know. Since you had a need for these patches, I'm
> checking if there are bad bugs they fix, in which case they would be needed
> in rawhide.

You are already familiar with it - guest' screen dynamic re/sizing.
The last two Marc-André Lureau' commits provide, so to speak, consolation in this respect.
Although with them the screen sizing does not happen fully dynamic/automatic - xserver restart or log out is needed.

Also this probably has to do with the necessary changes on the Xfce' side.

So you do not have to spend time searching for what is at stake.

Ref.
https://bugs.freedesktop.org/show_bug.cgi?id=84599
https://bugzilla.gnome.org/show_bug.cgi?id=711216
Comment 8 Christophe Fergeau 2015-08-06 12:18:22 EDT
For what it's worth, this is also fixed in Rawhide now.
Comment 9 poma 2015-08-06 14:34:39 EDT
It's always worth.

Salutate.

Note You need to log in before you can comment on or make changes to this bug.