This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 125011 - Badness in interruptible_sleep_on at kernel/sched.c:1927
Badness in interruptible_sleep_on at kernel/sched.c:1927
Status: CLOSED DUPLICATE of bug 122929
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-01 22:12 EDT by Aleksey Nogin
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleksey Nogin 2004-06-01 22:12:33 EDT
On a FC2 machine (upgraded from FC1, fully up2date, no selinux
installed), I keep getting these "Badness" messages:

Badness in interruptible_sleep_on at kernel/sched.c:1927
Call Trace:
 [<0227ee1e>] interruptible_sleep_on+0x5a/0xa7
 [<02115e97>] default_wake_function+0x0/0xc
 [<02181229>] inode_has_perm+0x57/0x5f
 [<42856267>] autofs4_wait+0x1c6/0x200 [autofs4]
 [<4285555c>] try_to_fill_dentry+0x1f/0xdb [autofs4]
 [<0214af60>] do_lookup+0x54/0x72
 [<0214b219>] link_path_walk+0x29b/0x6e2
 [<0214d939>] vfs_follow_link+0xbf/0x121
 [<42a5006c>] nfs_follow_link+0x1e/0x3a [nfs]
 [<0214b2dc>] link_path_walk+0x35e/0x6e2
 [<0214d939>] vfs_follow_link+0xbf/0x121
 [<42a5006c>] nfs_follow_link+0x1e/0x3a [nfs]
 [<0214b2dc>] link_path_walk+0x35e/0x6e2
 [<0214b8b3>] path_lookup+0xf8/0x128
 [<0214b9ef>] __user_walk+0x21/0x51
 [<02147d02>] vfs_stat+0x14/0x3a
 [<02148274>] sys_stat64+0xf/0x23

Badness in interruptible_sleep_on at kernel/sched.c:1927
Call Trace:
 [<0227ee1e>] interruptible_sleep_on+0x5a/0xa7
 [<02115e97>] default_wake_function+0x0/0xc
 [<02181229>] inode_has_perm+0x57/0x5f
 [<42856267>] autofs4_wait+0x1c6/0x200 [autofs4]
 [<42855576>] try_to_fill_dentry+0x39/0xdb [autofs4]
 [<0214af60>] do_lookup+0x54/0x72
 [<0214b219>] link_path_walk+0x29b/0x6e2
 [<0214d939>] vfs_follow_link+0xbf/0x121
 [<42a5006c>] nfs_follow_link+0x1e/0x3a [nfs]
 [<0214b2dc>] link_path_walk+0x35e/0x6e2
 [<0214d939>] vfs_follow_link+0xbf/0x121
 [<42a5006c>] nfs_follow_link+0x1e/0x3a [nfs]
 [<0214b2dc>] link_path_walk+0x35e/0x6e2
 [<0214b8b3>] path_lookup+0xf8/0x128
 [<0214b9ef>] __user_walk+0x21/0x51
 [<02147d02>] vfs_stat+0x14/0x3a
 [<02135342>] follow_page+0xda/0xe5
 [<02148274>] sys_stat64+0xf/0x23
 [<0214df33>] locate_fd+0xee/0x119
 [<0214e26c>] generic_file_fcntl+0xd7/0x140
 [<0214e3c9>] sys_fcntl64+0x6a/0x7b
 [<0214e3d3>] sys_fcntl64+0x74/0x7b

Badness in interruptible_sleep_on at kernel/sched.c:1927
Call Trace:
 [<0227ee1e>] interruptible_sleep_on+0x5a/0xa7
 [<02115e97>] default_wake_function+0x0/0xc
 [<02181229>] inode_has_perm+0x57/0x5f
 [<42856267>] autofs4_wait+0x1c6/0x200 [autofs4]
 [<4285555c>] try_to_fill_dentry+0x1f/0xdb [autofs4]
 [<0214af60>] do_lookup+0x54/0x72
 [<0214b219>] link_path_walk+0x29b/0x6e2
 [<0214d939>] vfs_follow_link+0xbf/0x121
 [<42a5006c>] nfs_follow_link+0x1e/0x3a [nfs]
 [<0214b2dc>] link_path_walk+0x35e/0x6e2
 [<0214d939>] vfs_follow_link+0xbf/0x121
 [<42a5006c>] nfs_follow_link+0x1e/0x3a [nfs]
 [<0214b2dc>] link_path_walk+0x35e/0x6e2
 [<0214b8b3>] path_lookup+0xf8/0x128
 [<0214b9ef>] __user_walk+0x21/0x51
 [<02147d02>] vfs_stat+0x14/0x3a
 [<02148274>] sys_stat64+0xf/0x23
 [<02114408>] do_page_fault+0x0/0x446

Badness in interruptible_sleep_on at kernel/sched.c:1927
Call Trace:
 [<0227ee1e>] interruptible_sleep_on+0x5a/0xa7
 [<02115e97>] default_wake_function+0x0/0xc
 [<02181229>] inode_has_perm+0x57/0x5f
 [<42856267>] autofs4_wait+0x1c6/0x200 [autofs4]
 [<42855576>] try_to_fill_dentry+0x39/0xdb [autofs4]
 [<0214af60>] do_lookup+0x54/0x72
 [<0214b219>] link_path_walk+0x29b/0x6e2
 [<0214d939>] vfs_follow_link+0xbf/0x121
 [<42a5006c>] nfs_follow_link+0x1e/0x3a [nfs]
 [<0214b2dc>] link_path_walk+0x35e/0x6e2
 [<0214d939>] vfs_follow_link+0xbf/0x121
 [<42a5006c>] nfs_follow_link+0x1e/0x3a [nfs]
 [<0214b2dc>] link_path_walk+0x35e/0x6e2
 [<0214b8b3>] path_lookup+0xf8/0x128
 [<0214b9ef>] __user_walk+0x21/0x51
 [<02147d02>] vfs_stat+0x14/0x3a
 [<02148274>] sys_stat64+0xf/0x23
 [<02114408>] do_page_fault+0x0/0x446

Badness in interruptible_sleep_on at kernel/sched.c:1927
Call Trace:
 [<0227ee1e>] interruptible_sleep_on+0x5a/0xa7
 [<02115e97>] default_wake_function+0x0/0xc
 [<02181229>] inode_has_perm+0x57/0x5f
 [<42856267>] autofs4_wait+0x1c6/0x200 [autofs4]
 [<428555c8>] try_to_fill_dentry+0x8b/0xdb [autofs4]
 [<0214af60>] do_lookup+0x54/0x72
 [<0214b219>] link_path_walk+0x29b/0x6e2
 [<0214d939>] vfs_follow_link+0xbf/0x121
 [<42a5006c>] nfs_follow_link+0x1e/0x3a [nfs]
 [<0214b2dc>] link_path_walk+0x35e/0x6e2
 [<0214d939>] vfs_follow_link+0xbf/0x121
 [<42a5006c>] nfs_follow_link+0x1e/0x3a [nfs]
 [<0214b2dc>] link_path_walk+0x35e/0x6e2
 [<0214b8b3>] path_lookup+0xf8/0x128
 [<0214b9ef>] __user_walk+0x21/0x51
 [<02147d02>] vfs_stat+0x14/0x3a
 [<02135342>] follow_page+0xda/0xe5
 [<02148274>] sys_stat64+0xf/0x23
 [<0214df33>] locate_fd+0xee/0x119
 [<0214e26c>] generic_file_fcntl+0xd7/0x140
 [<0214e3c9>] sys_fcntl64+0x6a/0x7b
 [<0214e3d3>] sys_fcntl64+0x74/0x7b
Comment 1 Dave Jones 2004-06-02 12:55:08 EDT

*** This bug has been marked as a duplicate of 122929 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:03:55 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.