Bug 1250282 - save changes will return "Invalid Certification ID" if the corresponding bug has "Depends on" or "Blocks" which is not cert
save changes will return "Invalid Certification ID" if the corresponding bug ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Certification Program
Classification: Red Hat
Component: Certification Workflow Engine (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kun Yan
Suprith Gangawar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-04 22:07 EDT by Jianwei Weng
Modified: 2015-09-21 02:03 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-21 02:03:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jianwei Weng 2015-08-04 22:07:13 EDT
https://hardware.redhat.com/show.cgi?id=1221125 this is a hardware spec,its corresponding bug is https://bugzilla.redhat.com/show_bug.cgi?id=1221125 ,it's the block of https://bugzilla.redhat.com/show_bug.cgi?id=1105196 which is used by HP to track HP cert,so actually the #1105196 is not a cert ID but a bug ID.
When saving changes of https://hardware.redhat.com/show.cgi?id=1221125 it will return errors:

Invalid Certification ID
The cert with bug id#1105196 does not exist.
Please press Back and try again.

Seems CWE will check the "depends on" or "blocks" and the IDs must be cert IDs,otherwise it will return error.

Sometimes,vendor may use "depends on" or "blocks" to track issues or certs,we should allow this value to be bug ID as well.

Please help to fix this bug as soon as possible.
Comment 1 Jianwei Weng 2015-08-04 22:15:17 EDT
I removed the 1105196 from the blocks of 1221125 because reporter will save changes for this cert.
Comment 2 Hong Tao 2015-08-05 01:06:39 EDT
Hi, Rob,

Do we need to allow vendors to set 'dependson' to a bug (not a cert)? If we need, I would like to take this issue to do some modification. If we don't need, just ask the reviewers to delete them will be OK. What is your opinion? Thanks a lot for your kindly help!

Best Regards,
Hong Tao
Comment 3 Rob Landry 2015-08-05 19:44:38 EDT
(In reply to Hong Tao from comment #2)
> Hi, Rob,
> 
> Do we need to allow vendors to set 'dependson' to a bug (not a cert)? If we
> need, I would like to take this issue to do some modification. If we don't
> need, just ask the reviewers to delete them will be OK. What is your
> opinion? Thanks a lot for your kindly help!
> 
> Best Regards,
> Hong Tao

It should not break things to have set a depends on that is not a cert.  We don't have support and suggest vendors should not use bz directly, however outside of that it's reasonable that a partner might set a depends on a RHEL bug to show that it is blocking a certification so it seems correct to fix this.  

The "advanced" tab has an 'other' relationship type as well which is where this kind of linking should appear in the UI although it is not controllable from there.

Note You need to log in before you can comment on or make changes to this bug.