Bug 1250299 - impossible to read repositories of COPR
impossible to read repositories of COPR
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: dnf-plugins-core (Show other bugs)
22
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Miroslav Suchý
Fedora Extras Quality Assurance
:
: 1246832 1251894 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-05 00:50 EDT by David Vásquez
Modified: 2015-08-11 10:38 EDT (History)
16 users (show)

See Also:
Fixed In Version: dnf-plugins-core-0.1.10-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-10 06:42:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Vásquez 2015-08-05 00:50:24 EDT
Description of problem:
When I install any repository from COPR; Is impossible to read repositories.

Version-Release number of selected component (if applicable):


How reproducible:

dnf provides chromium

Steps to Reproduce:
su
dnf copr enable spot/chromium

dnf clean metadata
dnf provides chromium

Actual results:

[makerpm@localhost ~]$ dnf provides chromium
Warning: failed loading '/etc/yum.repos.d/_copr_spot-chromium.repo', skipping.
Last metadata expiration check performed 5:06:42 ago on Tue Aug  4 17:29:51 2015.
Error: No Matches found

Expected results:
chromium-??.0.-1.fc22.x86_64 : The open-source project behind Google Chrome, an attempt at creating a safer, faster, and more stable browser
Repo        : copr/spot-chromium

Additional info:
When you see the file is unreadable
cat /etc/yum.repos.d/_copr_spot-chromium.repo

[makerpm@localhost ~]$ cat /etc/yum.repos.d/_copr_spot-chromium.repo
cat: /etc/yum.repos.d/_copr_spot-chromium.repo: Permission denied

Also if you see the repository example in Thunar, can you see a "X" "_copr_spot-chromium.repo" in the picture.
http://s28.postimg.org/g05nm7er1/cos.png
Comment 1 David Vásquez 2015-08-05 03:24:53 EDT
But if you apply a simple

su
chmod a+r _copr_spot-chromium.repo

It resolves the problem; I think so is a problem about permit...
Comment 2 Honza Silhan 2015-08-07 07:24:10 EDT
Maybe it's already fixed in the upstream [1]. Mirek, can you confirm?

[1] https://github.com/rpm-software-management/dnf-plugins-core/commit/d69922fbf9db4461d9dca337033fddf74cf9c15d
Comment 3 Miroslav Suchý 2015-08-10 06:39:55 EDT
Yes. Fixed in commit 
* d69922f copr: set chmod to rw-r--r-- on repo files
Comment 4 Miroslav Suchý 2015-08-10 06:42:27 EDT
Already built for rawhide and included in this errata for F23:
https://admin.fedoraproject.org/updates/dnf-plugins-core-0.1.10-1.fc23,dnf-1.1.0-1.fc23,hawkey-0.6.0-1.fc23
Comment 5 Miro Hrončok 2015-08-10 10:29:16 EDT
Any chance for fix for F22 as well?
Comment 6 Honza Silhan 2015-08-10 10:35:43 EDT
*** Bug 1246832 has been marked as a duplicate of this bug. ***
Comment 7 Radek Holy 2015-08-11 10:38:12 EDT
*** Bug 1251894 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.