Bug 125030 - xhtml1-dtds should BuildRequires: libxml2
xhtml1-dtds should BuildRequires: libxml2
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: xhtml1-dtds (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-02 06:55 EDT by Maxim Dziumanenko
Modified: 2007-04-18 13:08 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-02 10:14:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Maxim Dziumanenko 2004-06-02 06:55:53 EDT
Description of problem:
xmlcatalog binary is needed to build xhtml1-dtds

Version-Release number of selected component (if applicable):
xhtml1-dtds-1.0-6

How reproducible:
Always

Steps to Reproduce:
1.rpm -e libxml2
2.rpmbuild --rebuild xhtml1-dtds-1.0-6.src.rpm
3.Wait for errors
  
Actual results:


Expected results:


Additional info:
Comment 1 Daniel Veillard 2004-06-02 07:10:38 EDT
xmlcatalog is only needed for %pre and %post, could you provide the
errors your are seeing because they should not occur ? 

  thanks

Daniel
Comment 2 Maxim Dziumanenko 2004-06-02 10:00:20 EDT
%install section of xhtml1-dtds contains: 

/usr/bin/xmlcatalog --noout --create $CATALOG
/usr/bin/xmlcatalog --noout --add "public" \
    "-//W3C//DTD XHTML 1.0 Strict//EN" \
    "xhtml1-20020801/DTD/xhtml1-strict.dtd" $CATALOG
...

Comment 3 Daniel Veillard 2004-06-02 10:14:03 EDT
Okay, fix made into xhtml1-dtds-1.0-7.src.rpm , 
it should show up on Rawhide at some point,

 thanks,

Daniel

Note You need to log in before you can comment on or make changes to this bug.