Bug 1250302 - [abrt] libreoffice-core: shared_count(): soffice.bin killed by SIGSEGV
[abrt] libreoffice-core: shared_count(): soffice.bin killed by SIGSEGV
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
21
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:6bd16fbf89947c3df1f8417365a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-05 01:13 EDT by Matt Hirsch
Modified: 2015-08-11 04:26 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-11 04:26:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (117.16 KB, text/plain)
2015-08-05 01:13 EDT, Matt Hirsch
no flags Details
File: cgroup (191 bytes, text/plain)
2015-08-05 01:13 EDT, Matt Hirsch
no flags Details
File: core_backtrace (90.36 KB, text/plain)
2015-08-05 01:13 EDT, Matt Hirsch
no flags Details
File: dso_list (29.38 KB, text/plain)
2015-08-05 01:13 EDT, Matt Hirsch
no flags Details
File: environ (2.08 KB, text/plain)
2015-08-05 01:13 EDT, Matt Hirsch
no flags Details
File: limits (1.29 KB, text/plain)
2015-08-05 01:13 EDT, Matt Hirsch
no flags Details
File: maps (146.38 KB, text/plain)
2015-08-05 01:13 EDT, Matt Hirsch
no flags Details
File: open_fds (4.33 KB, text/plain)
2015-08-05 01:13 EDT, Matt Hirsch
no flags Details
File: proc_pid_status (997 bytes, text/plain)
2015-08-05 01:13 EDT, Matt Hirsch
no flags Details
File: fail.odp (1.05 MB, application/octet-stream)
2015-08-05 01:13 EDT, Matt Hirsch
no flags Details

  None (edit)
Description Matt Hirsch 2015-08-05 01:13:02 EDT
Description of problem:
1. Insert a video into a new impress presentation
2. Click away from the video
3. Click on the video

Alternatively...

1. Open an impres presentation containing a video
2. Click on the video
3. Click away from the video
4. Click on the video

I will upload a presentation that causes this.

Version-Release number of selected component:
libreoffice-core-4.3.7.2-9.fc21

Additional info:
reporter:       libreport-2.3.0
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --impress --splash-pipe=5
crash_function: shared_count
executable:     /usr/lib64/libreoffice/program/soffice.bin
kernel:         4.0.8-200.fc21.x86_64
runlevel:       N 5
type:           CCpp
uid:            18823

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 shared_count at /usr/include/boost/smart_ptr/detail/shared_count.hpp:377
 #1 shared_ptr at /usr/include/boost/smart_ptr/shared_ptr.hpp:397
 #2 operator= at /usr/include/boost/smart_ptr/shared_ptr.hpp:507
 #4 OutputDevice::SetSettings at /usr/src/debug/libreoffice-4.3.7.2/vcl/source/outdev/outdev.cxx:283
 #5 Window::SetSettings at /usr/src/debug/libreoffice-4.3.7.2/vcl/source/window/window.cxx:4626
 #7 VCLXAccessibleComponent::FillAccessibleStateSet at /usr/src/debug/libreoffice-4.3.7.2/toolkit/source/awt/vclxaccessiblecomponent.cxx:457
 #8 VCLXAccessibleComponent::getAccessibleStateSet at /usr/src/debug/libreoffice-4.3.7.2/toolkit/source/awt/vclxaccessiblecomponent.cxx:661
 #9 comphelper::OAccessibleContextWrapper::getAccessibleStateSet at /usr/src/debug/libreoffice-4.3.7.2/comphelper/source/misc/accessiblewrapper.cxx:596
 #10 AtkListener::updateChildList at /usr/src/debug/libreoffice-4.3.7.2/vcl/unx/gtk/a11y/atklistener.cxx:125
 #11 AtkListener::handleChildRemoved at /usr/src/debug/libreoffice-4.3.7.2/vcl/unx/gtk/a11y/atklistener.cxx:199
Comment 1 Matt Hirsch 2015-08-05 01:13:06 EDT
Created attachment 1059304 [details]
File: backtrace
Comment 2 Matt Hirsch 2015-08-05 01:13:08 EDT
Created attachment 1059305 [details]
File: cgroup
Comment 3 Matt Hirsch 2015-08-05 01:13:09 EDT
Created attachment 1059306 [details]
File: core_backtrace
Comment 4 Matt Hirsch 2015-08-05 01:13:10 EDT
Created attachment 1059307 [details]
File: dso_list
Comment 5 Matt Hirsch 2015-08-05 01:13:11 EDT
Created attachment 1059308 [details]
File: environ
Comment 6 Matt Hirsch 2015-08-05 01:13:13 EDT
Created attachment 1059309 [details]
File: limits
Comment 7 Matt Hirsch 2015-08-05 01:13:15 EDT
Created attachment 1059310 [details]
File: maps
Comment 8 Matt Hirsch 2015-08-05 01:13:17 EDT
Created attachment 1059311 [details]
File: open_fds
Comment 9 Matt Hirsch 2015-08-05 01:13:18 EDT
Created attachment 1059312 [details]
File: proc_pid_status
Comment 10 Matt Hirsch 2015-08-05 01:13:22 EDT
Created attachment 1059313 [details]
File: fail.odp
Comment 11 Caolan McNamara 2015-08-09 09:23:47 EDT
can't reproduce (yet), but I imagine this is an accessibility crash given the stack
Comment 12 Matt Hirsch 2015-08-09 12:09:46 EDT
I just updated to F22, and I don't hit this bug under F22, which is

libreoffice-core-4.4.4.3-6.fc22.x86_64
gstreamer1-1.4.5-1.fc22.x86_64
kernel-4.1.3-201.fc22.x86_64

Maybe it's been resolved in this version.
Comment 13 Caolan McNamara 2015-08-11 04:26:55 EDT
Original reporter states its good in f22, so lets call this resolved.

Note You need to log in before you can comment on or make changes to this bug.