Bug 1250354 - Can we switch weka to the 3.7 branch?
Can we switch weka to the 3.7 branch?
Status: NEW
Product: Fedora
Classification: Fedora
Component: weka (Show other bugs)
28
All All
unspecified Severity low
: ---
: ---
Assigned To: Orphan Owner
Fedora Extras Quality Assurance
:
: 1510267 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-05 04:39 EDT by Michael Clerx
Modified: 2018-02-20 10:34 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Clerx 2015-08-05 04:39:52 EDT
Weka uses an unusual version numbering system. According to the website: "Weka 3.6 is the latest stable version of Weka, and the one described in the 3rd edition of the data mining book. This branch of Weka receives bug fixes only (for new features in Weka see the developer version)".

In other words, no new features will ever be added to 3.6, which was first released in 2008.

Switching to 3.7 would allow users to benefit from the last 7 years of development and is much more in line with Fedora's approach to other packages.
Comment 1 Michael Clerx 2015-08-07 05:00:51 EDT
The 3.7 branch also comes with a 256x256 icon, so it fixes bug 1157585
Comment 2 Fedora Admin XMLRPC Client 2015-09-30 15:24:49 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 gil cattaneo 2015-10-12 15:27:31 EDT
(In reply to Michael Clerx from comment #0)
> Weka uses an unusual version numbering system. According to the website:
> "Weka 3.6 is the latest stable version of Weka, and the one described in the
> 3rd edition of the data mining book. This branch of Weka receives bug fixes
> only (for new features in Weka see the developer version)".
> 
> In other words, no new features will ever be added to 3.6, which was first
> released in 2008.
> 
> Switching to 3.7 would allow users to benefit from the last 7 years of
> development and is much more in line with Fedora's approach to other
> packages.

need some work for disable org.pentaho.pentaho-commons:pentaho-package-manager:1.0.11 support
Comment 4 gil cattaneo 2015-10-12 15:54:47 EDT
Latest weka (3.7.13) release depend on java_cup >= 0.11b
Comment 5 Jan Kurik 2016-02-24 10:41:37 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 6 gil cattaneo 2016-05-28 05:46:21 EDT
Also the newer release use some dependencies which are not available
weka 3.8.0 and 3.9.0 use:

com.googlecode.matrix-toolkits-java:mtj:1.0.4
net.sourceforge.f2j:arpack_combined_all:0.1
com.googlecode.netlib-java:netlib-java:1.1
nz.ac.waikato.cms.weka.thirdparty:bounce:0.18
maybe this one could be replaced by
edankert.com:bounce:0.19

I think this package should be retired, if somethings does not changed with the dependencies ...
Comment 7 Jan Kurik 2016-07-26 00:16:41 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 25 development cycle.
Changing version to '25'.
Comment 8 gil cattaneo 2017-11-08 08:01:08 EST
*** Bug 1510267 has been marked as a duplicate of this bug. ***
Comment 9 Fedora End Of Life 2018-02-20 10:34:51 EST
This bug appears to have been reported against 'rawhide' during the Fedora 28 development cycle.
Changing version to '28'.

Note You need to log in before you can comment on or make changes to this bug.