Bug 125042 - gstreamer should BuildRequires: cvs, ghostscript
Summary: gstreamer should BuildRequires: cvs, ghostscript
Status: CLOSED DUPLICATE of bug 126071
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: gstreamer (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Colin Walters
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-02 11:40 UTC by Maxim Dziumanenko
Modified: 2007-04-18 17:08 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:03:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Maxim Dziumanenko 2004-06-02 11:40:09 UTC
Description of problem:
cvs (for autogen.sh), gs from ghostscript package are needed to build
gstreamer

Version-Release number of selected component (if applicable):
gstreamer-0.8.1-1

How reproducible:
Always

Steps to Reproduce:
1.rpm -e cvs ghostscript
2.rpmbuild --rebuild gstreamer-0.8.1-1.src.rpm
3.Wait for errors
  
Actual results:


Expected results:


Additional info:

Comment 1 Colin Walters 2004-06-21 16:19:37 UTC
The cvs dependency is actually a gettext-devel bug (#126071).

Can you give me the error that implies ghostscript is required?

Comment 2 Maxim Dziumanenko 2004-06-21 17:56:12 UTC
Making all in manual
make[3]: Entering directory
`/usr/src/mylinux/BUILD/gstreamer-0.8.1/docs/manual'
Generating build/images/bin-element-ghost.png from bin-element-ghost.fig
sh: line 1: gs: command not found
fig2dev: broken pipe (GhostScript aborted?)
command was: gs -q -dSAFER -sDEVICE=png16m -r80 -g577x192
-sOutputFile=build/images/bin-element-ghost.png -
make[3]: *** [build/images/bin-element-ghost.png] Error 1
make[3]: Leaving directory
`/usr/src/mylinux/BUILD/gstreamer-0.8.1/docs/manual'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/usr/src/mylinux/BUILD/gstreamer-0.8.1/docs'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/mylinux/BUILD/gstreamer-0.8.1'
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.3 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.3 (%build)
    
    

Comment 3 Colin Walters 2004-06-21 18:06:54 UTC
Thanks for the info, makes sense.

I added a BR on ghostscript.  I also changed BR: gettext to BR:
gettext-devel.  Then once bug 126071 is fixed, gettext-devel will pull
in cvs.

*** This bug has been marked as a duplicate of 126071 ***

Comment 4 Red Hat Bugzilla 2006-02-21 19:03:55 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.