Bug 1250563 - vdsm identifies the host as localhost instead of true hostname [NEEDINFO]
vdsm identifies the host as localhost instead of true hostname
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node (Show other bugs)
3.5.4
Unspecified Unspecified
medium Severity high
: ovirt-3.6.3
: ---
Assigned To: Douglas Schilling Landgraf
Huijuan Zhao
node
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-05 09:09 EDT by Anatoly Litovsky
Modified: 2016-02-10 14:17 EST (History)
18 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-30 16:13:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
fdeutsch: needinfo? (tlitovsk)


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 44454 master ABANDONED defaults: Hostname - remove alias manipulation Never

  None (edit)
Description Anatoly Litovsky 2015-08-05 09:09:43 EDT
Description of problem:
vdsm identifies the host as localhost instead of true hostname

Version-Release number of selected component (if applicable):
vdsm-4.16.24.5.git290f439


How reproducible:
100%

Steps to Reproduce:
1.auto register the engine using 
BOOTIF=eth0 ssh_pwauth=1 adminpw=ovonFQQPIAM9o  storage_init=/dev/sda management_server=192.168.100.100 hostname=node1 ip=192.168.100.111 netmask=255.255.255.0 gateway=192.168.100.1
2.The host will appear on engine as localhost
3.The host TUI shows hostname node1

Actual results:
The host will appear on engine as localhost

Expected results:
The host will appear on engine as node1

Additional info:
Comment 1 Douglas Schilling Landgraf 2015-08-05 10:09:59 EDT
Taking now, to review this registration bug.
Comment 2 Anatoly Litovsky 2015-08-05 11:32:49 EDT
the occurance is 100% on powerfull machines 
and around 50% on less powerfull
Comment 3 Douglas Schilling Landgraf 2015-08-06 22:34:58 EDT
I am moving to ovirt-node component as this initial patch is in ovirt-node.
Comment 4 Chaofeng Wu 2015-08-14 06:26:01 EDT
Cannot reproduce.

Version-Release number of selected component (if applicable):
rhev-hypervisor-7-7.1-20150805.0

Steps to Reproduce:
1, PXE install with the following arguments:
management_server=192.168.20.134 ip=192.168.20.173 hostname=node1 gateway=192.168.20.2 netmask=255.255.255.0 BOOTIF=enp32s0f1 adminpw=OKr05SbCu3D3g storage_init=/dev/sda reinstall ssh_pwauth=1

Additional info:
The host name appear on RHEVM as node1, and the host status is up. The host name appear on TUI as node1.

The output of the commands:
[root@node1 admin]# hostname
node1
[root@node1 admin]# hostname -f
localhost.localdomain
[root@node1 admin]# hostname --all-fqdn
node1 node1
Comment 5 Chaofeng Wu 2015-09-08 04:31:29 EDT
Hi tlitovsk,

We cannot reproduce this bug on our site and I notice that there is a patch for this bug.

If this patch is merged into RHEV-H target build in the feature, I want to know could you help us to verify this bug on RHEV-H target build ?

If you cannot verify this bug, we need to ask patch owner to provide the detail steps to do sanity only test to verify this bug.

Thanks,
Chaofeng
Comment 6 Fabian Deutsch 2015-10-23 03:58:03 EDT
I wonder if the root cause of this issue is the same as with the other dhcp localhos.localdomain problem like bug 1254580
Comment 7 Sandro Bonazzola 2015-10-26 08:36:25 EDT
this is an automated message. oVirt 3.6.0 RC3 has been released and GA is targeted to next week, Nov 4th 2015.
Please review this bug and if not a blocker, please postpone to a later release.
All bugs not postponed on GA release will be automatically re-targeted to

- 3.6.1 if severity >= high
- 4.0 if severity < high
Comment 8 Fabian Deutsch 2015-11-03 09:32:46 EST
Moving this out for now, because it's not clear what the root cause is.
Comment 11 Fabian Deutsch 2015-11-17 07:11:08 EST
Lowering the priority because QE can not reproduce it, see comment 5.
Comment 12 Fabian Deutsch 2015-11-23 10:42:30 EST
Tolik, can you still reproduce this issue?
Otherwise I tend to close it and abandon the patch.

It might be related to bug 1232338.
Comment 13 Douglas Schilling Landgraf 2015-11-30 16:13:27 EST
Hi Tolik,

I have tried to reproduce your report using rhev-hypervisor7-7.2-20151123.0.iso but I couldn't (as Chaofeng Wu tried as well in comment#3). The vdsm in the iso is vdsm-4.16.30-1.el7ev. Closing this bug for now, in case it reappear, please re-open.

Note You need to log in before you can comment on or make changes to this bug.