Bug 1250614 - [Doc Bug Fix] Changes from bug 1236119 should also appear in Installation Guide, chapter 3.3
[Doc Bug Fix] Changes from bug 1236119 should also appear in Installation Gui...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.4.0
Unspecified Unspecified
unspecified Severity unspecified
: post-GA
: EAP 6.4.3
Assigned To: sgilda
Ladislav Thon
: Documentation, EasyFix, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-05 10:58 EDT by Ladislav Thon
Modified: 2015-10-20 08:46 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-20 08:46:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ladislav Thon 2015-08-05 10:58:31 EDT
Changes produced as a result of bug 1236119 are present in the Migration Guide. However, the same kind of information is also present in the Installation Guide, chapter 3.3. These should be somehow kept in sync.
Comment 1 wfink 2015-08-07 08:43:30 EDT
I would not add this here (two places to maintain)

I would vote for a introduction like this:

If this installation replace a former version you might conside to upgrade.
The migration guide will show aproaches for major/minor/micro updates
Comment 2 Ladislav Thon 2015-08-07 09:00:30 EDT
The problem is that there are _already_ two places that compete with the same type of content. It makes sense to me to have this content available both in Install Guide and Migration Guide, but it doesn't make sense to me that the content is different. Some information is available only in the Install Guide, some only in the Migration Guide.

AFAIK, documentation topics can be reused, so that the maintenance overhead doesn't increase. That would be my favorite solution.
Comment 3 Scott Mumford 2015-08-10 17:27:27 EDT
Hi Ladislav. You're correct in the assertion that we can reuse topics between books with minimal effort and maintenance overhead. 

Should all of Sande's new content (Migration Guide Chapter 2.4: "About Migrations and Upgrades" [44602]) be included, or only a subset of it?

Also, Sande, should we need to, would you be willing to work with conditional tagging in the Migration Guide content?
Comment 4 sgilda 2015-08-10 17:37:40 EDT
Hi Scott, I'd be happy to. I'll grab this bug.
Comment 5 Ladislav Thon 2015-08-11 03:22:25 EDT
I took a quick look at chapter 2.4 About Migrations and Upgrades in the Migration Guide again and I think that:

- the Major Upgrades part probably doesn't need to be in the Installation Guide
- the Minor Updates part directly competes with chapter 3.3. Upgrading JBoss EAP 6 of the Installation Guide (mostly with 3.3.1 and 3.3.2)
- the Cumulative Patches part seems to summarize chapters 3.1. About Patches and Upgrades and 3.2. Patching JBoss EAP 6 and so doesn't need to be in the Installation Guide

Which, to me, results in the need to somehow merge the "Minor Updates" part of chapter 2.4 About Migrations and Upgrades in the Migration Guide with chapter 3.3. Upgrading JBoss EAP 6 of the Installation Guide. They both contain important information that is missing from the other part.
Comment 10 sgilda 2015-08-12 08:24:05 EDT
Thanks Ladislav. I will move this to ON_QA after the next build.
Comment 12 sgilda 2015-08-13 18:06:04 EDT
Thanks Wolf!

Note You need to log in before you can comment on or make changes to this bug.