Bug 1250615 - firewalld updates breaks connection between docker images
firewalld updates breaks connection between docker images
Status: CLOSED DUPLICATE of bug 1244124
Product: Fedora
Classification: Fedora
Component: firewalld (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-05 10:59 EDT by Nikos Mavrogiannopoulos
Modified: 2015-08-06 07:39 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-06 07:39:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nikos Mavrogiannopoulos 2015-08-05 10:59:00 EDT
Description of problem:
Upgrading to firewalld 0.3.14 within Fedora22 broken my test suite which uses docker. It seems that after the update firewalld is denying connections between docker images. That cost me a day of debugging of figuring why everything suddenly stopped working.

Not only I find that change absurd, but despite that, _this is not a change to be introduced within the lifecycle of Fedora 22_. Please undo this policy and let F22 work as it initially did. If you need to introduce such a change please discuss it in the fedora security list and introduce a change request for F23 or F24.

Version-Release number of selected component (if applicable):
0.3.14.2-2.fc22 is broken
0.3.13 f22 works

How reproducible:
Create two docker images and try connect to each other using TCP.

Actual results:
Connection is timed out.

Expected results:
As with F22 release, connection is established.
Comment 1 Thomas Woerner 2015-08-06 06:48:35 EDT
Please have a look at #1244124

I think this is the same issue. A reload or restart of firewalld results in loosing the firewall rules for the containers. This is also the case for an update of firewalld.
Comment 2 Nikos Mavrogiannopoulos 2015-08-06 07:39:16 EDT
You are correct, a reboot using the new firewalld solved the issue. Sorry for the harsh language, the bug was written after a long day of debugging the issue.

*** This bug has been marked as a duplicate of bug 1244124 ***

Note You need to log in before you can comment on or make changes to this bug.