This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1250617 - Notifications from Firefox do not show when an icon is specified
Notifications from Firefox do not show when an icon is specified
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-05 11:00 EDT by Joe Borg
Modified: 2015-09-08 09:02 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-08 09:02:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Borg 2015-08-05 11:00:47 EDT
Description of problem:
I am guessing that this is a GNOME / Fedora issue, but it's only a guess.  If, from within Firefox, you create a notification without an icon, the notification shows in the tray.  However, adding an icon to the notification breaks this (but works in the same version of Firefox for Windows).

Version-Release number of selected component (if applicable):
Firefox 39.0
Gnome Shell 3.16.3

How reproducible:
100%

Steps to Reproduce:
1. Open Firefox and go to http://jsfiddle.net/jdb1991/Lucgu5d0/.
2. Accept the permissions for notifications.
3. Click 'Click me for no icon' - This works fine; the notification shows in Gnome notifications.
4. Click 'Click me for icon' - This doesn't show.  No JS error is thrown.

Actual results:
Nothing is shows

Expected results:
A Gnome notification with icon

Additional info:
Works in Chrome on Fedora (Chrome uses its own System).
Works in Firefox 39.0 for Windows.
Works in Firefox 39.0 for Mac.
Works in Firefox Mobile for Android.
Comment 1 Florian Müllner 2015-08-05 18:48:52 EDT
(In reply to Joe Borg from comment #0)
> Steps to Reproduce:
> 1. Open Firefox and go to http://jsfiddle.net/jdb1991/Lucgu5d0/.
> 2. Accept the permissions for notifications.
> 3. Click 'Click me for no icon' - This works fine; the notification shows in
> Gnome notifications.
> 4. Click 'Click me for icon' - This doesn't show.  No JS error is thrown.

I can reproduce this, but apparently Firefox only requests a notification in (3) and not (4), so reassigning.
Comment 2 Joe Borg 2015-08-07 09:07:39 EDT
In case it's useful, installing this plugin makes the notifications with icons work https://addons.mozilla.org/en-US/firefox/addon/gnotifier/
Comment 3 Martin Stransky 2015-09-08 09:02:02 EDT
It's because you has a wrong format of the notification. Correct one is:

new Notification('Title', {body: "message body", icon: "icon_url"});

Note You need to log in before you can comment on or make changes to this bug.