Bug 1250629 - AttributeError: 'DiskDevice' object has no attribute 'disk'
AttributeError: 'DiskDevice' object has no attribute 'disk'
Status: CLOSED DUPLICATE of bug 1240671
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:9a413b806830f05e9534b4d2e93...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-05 11:29 EDT by Prasenjit Das
Modified: 2015-08-06 14:33 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-06 14:33:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (1.56 MB, text/plain)
2015-08-05 11:31 EDT, Prasenjit Das
no flags Details
File: anaconda.log (44.43 KB, text/plain)
2015-08-05 11:31 EDT, Prasenjit Das
no flags Details
File: environ (613 bytes, text/plain)
2015-08-05 11:31 EDT, Prasenjit Das
no flags Details
File: journalctl (1.21 MB, text/plain)
2015-08-05 11:33 EDT, Prasenjit Das
no flags Details
File: lsblk_output (2.11 KB, text/plain)
2015-08-05 11:33 EDT, Prasenjit Das
no flags Details
File: nmcli_dev_list (1.54 KB, text/plain)
2015-08-05 11:33 EDT, Prasenjit Das
no flags Details
File: os_info (500 bytes, text/plain)
2015-08-05 11:33 EDT, Prasenjit Das
no flags Details
File: program.log (39.12 KB, text/plain)
2015-08-05 11:33 EDT, Prasenjit Das
no flags Details
File: storage.log (202.58 KB, text/plain)
2015-08-05 11:33 EDT, Prasenjit Das
no flags Details
File: ifcfg.log (2.70 KB, text/plain)
2015-08-05 11:33 EDT, Prasenjit Das
no flags Details

  None (edit)
Description Prasenjit Das 2015-08-05 11:29:28 EDT
Version-Release number of selected component:
anaconda-core-22.20.13-1.fc22.x86_64

The following was filed automatically by anaconda:
anaconda 22.20.13-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 369, in processActions
    if dep.exists and dep.dependsOn(action.device.disk):
  File "/usr/lib/python2.7/site-packages/blivet/blivet.py", line 162, in doIt
    self.devicetree.processActions(callbacks)
  File "/usr/lib/python2.7/site-packages/blivet/osinstall.py", line 1057, in turnOnFilesystems
    storage.doIt(callbacks)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 196, in doInstall
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall, callbacks=callbacks_reg)
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 244, in run
    threading.Thread.run(self, *args, **kwargs)
AttributeError: 'DiskDevice' object has no attribute 'disk'

Additional info:
cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=FEDORA-LIVE rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.0.4-301.fc22.x86_64
other involved packages: python-libs-2.7.9-6.fc22.x86_64, python-blivet-1.0.9-1.fc22.noarch
product:        Fedora
release:        Fedora release 22 (Twenty Two)
type:           anaconda
version:        22
Comment 1 Prasenjit Das 2015-08-05 11:31:46 EDT
Created attachment 1059519 [details]
File: anaconda-tb
Comment 2 Prasenjit Das 2015-08-05 11:31:49 EDT
Created attachment 1059520 [details]
File: anaconda.log
Comment 3 Prasenjit Das 2015-08-05 11:31:51 EDT
Created attachment 1059521 [details]
File: environ
Comment 4 Prasenjit Das 2015-08-05 11:33:13 EDT
Created attachment 1059522 [details]
File: journalctl
Comment 5 Prasenjit Das 2015-08-05 11:33:15 EDT
Created attachment 1059523 [details]
File: lsblk_output
Comment 6 Prasenjit Das 2015-08-05 11:33:17 EDT
Created attachment 1059524 [details]
File: nmcli_dev_list
Comment 7 Prasenjit Das 2015-08-05 11:33:19 EDT
Created attachment 1059525 [details]
File: os_info
Comment 8 Prasenjit Das 2015-08-05 11:33:22 EDT
Created attachment 1059526 [details]
File: program.log
Comment 9 Prasenjit Das 2015-08-05 11:33:35 EDT
Created attachment 1059527 [details]
File: storage.log
Comment 10 Prasenjit Das 2015-08-05 11:33:37 EDT
Created attachment 1059528 [details]
File: ifcfg.log
Comment 11 David Shea 2015-08-06 14:33:03 EDT

*** This bug has been marked as a duplicate of bug 1240671 ***

Note You need to log in before you can comment on or make changes to this bug.