Bug 125067 - Nautilus Crashes When Drag-And-Dropping a File to Samba Mountpoint
Nautilus Crashes When Drag-And-Dropping a File to Samba Mountpoint
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-02 10:54 EDT by George Salt
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: FC3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-22 17:25:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description George Salt 2004-06-02 10:54:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
I'm running fc2 with samba 3.0.3-5 installed.

I mounted a FAT32 share on a Windows machine (both Win98SE and Win2k)
using "smbmount //winbox/share /mountpoint"

Using Nautilus, I can navigate to the mountpoint and see the files on
the share.

When I drag-and-drop a file to the window of the mountpoint, I get the
following error box:

    The application "nautilus" has quit unexpectedly.  You can inform
the developers of what happened to help them fix it.  Or you can
restart the application right now.

When I hit the "restart button" the nautilus windows close.  When I
restart nautilus and navigate to the mountpoint, the file I
dragged-and-dropped previously is there. 

Version-Release number of selected component (if applicable):
nautilus-2.6.0-4

How reproducible:
Always

Steps to Reproduce:
1.  Mount remote share with smbmount
2.  Open nautilus, navigate to the mountpoint
3.  Drag-and-drop a file to the window opened at the mountpoint
    

Actual Results:  I get the following error box: 

The application "nautilus" has quit unexpectedly.  You can inform the
developers of what happened to help them fix it.  Or you can restart
the application right now.


Expected Results:  No error - nautilus should not quit unexpectedly

Additional info:
Comment 1 George Salt 2004-06-02 11:12:42 EDT
I should clarify - the crash occurs when I drop-and-drag a file from a
window for one remote share to a window for another remote share:

-- I mounted 2 different remote shares with smbmount.

-- I opened a nautilus window for each mountpoint

-- I try to drag-and-drop a file from one share to the other

I just tried dragging-and-dropping a local file to either share and
that works.
Comment 2 Alexander Larsson 2004-08-26 10:28:00 EDT
Any chance you could install the debuginfo packages for gnome-vfs2 and
nautilus and get a backtrace of the crash from gdb?
Comment 3 Alexander Larsson 2004-10-05 08:56:45 EDT
I tested this on fc3test3, and it worked for me. Can you retry with
fc3test3 or later and see if you still get this?
Comment 4 John Thacker 2006-04-22 17:25:43 EDT
No response from reporter for a year and a half after a request.  Works for me
on more recently releases.  Going to assume that it was fixed in FC3, and since
FC2 is Fedora Legacy now (and this isn't security), closing.

Note You need to log in before you can comment on or make changes to this bug.