Bug 1250727 - ISO based upgrade fails during install_package run
ISO based upgrade fails during install_package run
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Mike McCune
Sachin Ghai
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-05 16:30 EDT by Mike McCune
Modified: 2017-02-23 14:48 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-12 12:03:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
disconnedted upgrade (ISO) on rhel66 succeed (87.95 KB, image/png)
2015-08-07 04:45 EDT, Sachin Ghai
no flags Details

  None (edit)
Description Mike McCune 2015-08-05 16:30:45 EDT
If you attempt to update a 6.0.4 ISO based Satellite install via the *new* 6.1.0 ISO's install_packages script it ends up with a series of duplicate RPMs (old 6.0.4 AND 6.1.0 versions):

   - Katello is already installed, running 'yum upgrade'.
   - WARNING: Package GPG signatures will be ignored!
There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
Warning: RPMDB altered outside of yum.
** Found 36 pre-existing rpmdb problem(s), 'yum check' output follows:
candlepin-common-1.0.22-1.el6.noarch is a duplicate with candlepin-common-1.0.1-1.el6_5.noarch
elasticsearch-0.90.10-7.el6.noarch is a duplicate with elasticsearch-0.90.10-6.el6sat.noarch
pulp-puppet-tools-2.6.0.15-1.el6_6sat.noarch is a duplicate with pulp-puppet-tools-2.4.1-0.7.beta.el6sat.noarch
puppet-3.6.2-4.el6_6sat.noarch is a duplicate with puppet-3.6.2-1.el6sat.noarch
python-gofer-2.6.2-2.el6_6sat.noarch is a duplicate with python-gofer-1.3.0-1.el6sat.noarch
python-gofer-qpid-2.6.2-2.el6_6sat.noarch is a duplicate with python-gofer-qpid-1.3.0-1.el6sat.noarch
python-isodate-0.5.0-4.pulp.el6_6sat.noarch is a duplicate with python-isodate-0.5.0-1.pulp.el6sat.noarch
python-nectar-1.3.1-2.el6_6sat.noarch is a duplicate with python-nectar-1.3.1-1.el6sat.noarch
python-oauth2-1.5.211-8.el6_6sat.noarch is a duplicate with python-oauth2-1.5.211-5.el6sat.noarch
python-pulp-bindings-2.6.0.15-1.el6_6sat.noarch is a duplicate with python-pulp-bindings-2.4.1-0.7.beta.el6sat.noarch
python-pulp-common-2.6.0.15-1.el6_6sat.noarch is a duplicate with python-pulp-common-2.4.1-0.7.beta.el6sat.noarch
python-pulp-puppet-common-2.6.0.15-1.el6_6sat.noarch is a duplicate with python-pulp-puppet-common-2.4.1-0.7.beta.el6sat.noarch
python-pulp-rpm-common-2.6.0.15-1.el6_6sat.noarch is a duplicate with python-pulp-rpm-common-2.4.1-0.7.beta.el6sat.noarch
python-qpid-0.30-6.el6.noarch is a duplicate with python-qpid-0.22-14.el6sat.noarch
python-qpid-qmf-0.30-5.el6.x86_64 is a duplicate with python-qpid-qmf-0.22-37.el6.x86_64
qpid-cpp-client-0.30-9.el6.x86_64 is a duplicate with qpid-cpp-client-0.22-42.el6.x86_64
qpid-cpp-server-0.30-9.el6.x86_64 is a duplicate with qpid-cpp-server-0.22-42.el6.x86_64
qpid-cpp-server-linearstore-0.30-9.el6.x86_64 is a duplicate with qpid-cpp-server-linearstore-0.22-42.el6.x86_64
qpid-java-client-0.30-3.el6.noarch is a duplicate with qpid-java-client-0.22-6.el6.noarch
qpid-java-common-0.30-3.el6.noarch is a duplicate with qpid-java-common-0.22-6.el6.noarch
qpid-proton-c-0.9-4.el6.x86_64 is a duplicate with qpid-proton-c-0.7-1.el6.x86_64
qpid-qmf-0.30-5.el6.x86_64 is a duplicate with qpid-qmf-0.22-37.el6.x86_64
qpid-tools-0.30-4.el6.noarch is a duplicate with qpid-tools-0.22-12.el6.noarch
ruby193-rubygem-angular-rails-templates-0.1.2-1.el6_6sat.noarch is a duplicate with ruby193-rubygem-angular-rails-templates-0.0.4-5.el6sat.noarch
ruby193-rubygem-excon-0.38.0-1.el6_6sat.noarch is a duplicate with ruby193-rubygem-excon-0.32.1-2.el6sat.noarch
ruby193-rubygem-fog-core-1.24.0-1.el6_6sat.noarch is a duplicate with ruby193-rubygem-fog-core-1.21.1-2.el6sat.noarch
ruby193-rubygem-fog-json-1.0.0-2.1.el6_6sat.noarch is a duplicate with ruby193-rubygem-fog-json-1.0.0-2.el6sat.noarch
ruby193-rubygem-redhat_access_lib-0.0.4-1.el6_6sat.noarch is a duplicate with ruby193-rubygem-redhat_access_lib-0.0.1-1.el6sat.noarch
rubygem-apipie-bindings-0.0.11-1.el6_6sat.noarch is a duplicate with rubygem-apipie-bindings-0.0.8-1.el6sat.noarch
rubygem-hammer_cli-0.1.4.11-1.el6_6sat.noarch is a duplicate with rubygem-hammer_cli-0.1.1-12.el6sat.noarch
rubygem-hammer_cli_foreman-0.1.4.14-1.el6_6sat.noarch is a duplicate with rubygem-hammer_cli_foreman-0.1.1-16.el6sat.noarch
rubygem-hammer_cli_foreman_tasks-0.0.3.5-1.el6_6sat.noarch is a duplicate with rubygem-hammer_cli_foreman_tasks-0.0.3-3.el6sat.noarch
rubygem-hammer_cli_import-0.10.19-1.el6_6sat.noarch is a duplicate with rubygem-hammer_cli_import-0.10.4-1.1.el6sat.noarch
rubygem-hammer_cli_katello-0.0.7.17-1.el6_6sat.noarch is a duplicate with rubygem-hammer_cli_katello-0.0.4-14.el6sat.noarch
rubygem-kafo-0.6.5.9-1.el6_6sat.noarch is a duplicate with rubygem-kafo-0.6.4-2.el6sat.noarch
rubygem-kafo_parsers-0.0.4.4-1.el6_6sat.noarch is a duplicate with rubygem-kafo_parsers-0.0.3-2.el6sat.noarch
   - Installation repository will remain configured for future package installs.
   - Installation media can now be safely unmounted.

Upgrade is complete. Please backup your data and run katello-installer.

this is fatal.
Comment 4 Sachin Ghai 2015-08-07 04:37:51 EDT
Ok, I installed sat6.0.4 from ISO on rhel66 along with rhel66 DVD iso. Installation was successful.

Later I upgraded the rhel66 with rhel67 DVD ISO. And ran install_script from sat6.1 ISO (ISO from link mentioned in comment13) to perform yum update. Here is the result. Its completed successfully.

---
repo id                                                         repo name                                                                       status
rhel66dvd                                                       Red Hat Enterprise Linux 6.6                                                    3,785
rhel67dvd                                                       Red Hat Enterprise Linux 6.7                                                    3,819
katello-local                                                   katello-local                                                                     345
scl-local                                                       scl-local                                                                         826
repolist: 8,775
[root@cloud-qe-6 yum.repos.d]# cd
[root@cloud-qe-6 ~]# cd /media/sat61/
[root@cloud-qe-6 sat61]# ls
install_packages  media.repo  Packages  repodata  RHSCL  TRANS.TBL
[root@cloud-qe-6 sat61]# ./install_packages 
This script will install the katello packages on the current machine.
   - Ensuring we are in an expected directory.
   - Copying installation files.
   - Creating a Repository File
   - Creating RHSCL Repository File
   - Checking to see if Katello is already installed.
   - Katello is already installed, running 'yum update'.
   - Installation repository will remain configured for future package installs.
   - Installation media can now be safely unmounted.

Upgrade is complete. Please backup your data and run katello-installer.
[root@cloud-qe-6 sat61]# 
[root@cloud-qe-6 sat61]# katello-installer --upgrade
Upgrading...
Upgrade Step: stop_services...
Upgrade Step: start_mongo...
Upgrade Step: migrate_pulp...
Upgrade Step: start_httpd...
Upgrade Step: migrate_candlepin...
Upgrade Step: migrate_foreman...
Upgrade Step: Running installer...
Installing             Done                                               [100%] [..................................................................]
  The full log is at /var/log/katello-installer/katello-installer.log
Upgrade Step: restart_services...
Upgrade Step: db_seed...
Upgrade Step: errata_import (this may take a while) ...
Upgrade Step: update_gpg_urls (this may take a while) ...
Upgrade Step: update_repository_metadata (this may take a while) ...
Katello upgrade completed!
[root@cloud-qe-6 sat61]# 


so upgrade via ISO from sat6.0.4 to sat6.1 on rhel66 (given compose link) works fine. Thanks
Comment 5 Sachin Ghai 2015-08-07 04:44:02 EDT
Please note that I installed sat6.0.4 on rhel66 via iso. And later upgraded the rhel66 to rhel67 via dvd iso (before satellite upgrade). Then upgraded the satellite with sat6.1 ISO.
Comment 6 Sachin Ghai 2015-08-07 04:45:40 EDT
Created attachment 1060262 [details]
disconnedted upgrade (ISO) on rhel66 succeed
Comment 7 Sachin Ghai 2015-08-07 04:54:20 EDT
On rhel71, install script fails while upgrade due to following package:

[root@cloud-qe-19 sat61]# ./install_packages 
This script will install the katello packages on the current machine.
   - Ensuring we are in an expected directory.
   - Copying installation files.
   - Creating a Repository File
   - Creating RHSCL Repository File
   - Checking to see if Katello is already installed.
   - Katello is already installed, running 'yum update'.
Error: Package: python-nectar-1.3.1-2.el7sat.noarch (katello-local)
           Requires: python-requests >= 2.4.3
           Installed: python-requests-2.2.1-1.el7sat.noarch (@katello-local)
               python-requests = 2.2.1-1.el7sat
           Available: python-requests-1.1.0-8.el7.noarch (rhel70dvd)
               python-requests = 1.1.0-8.el7

rhel71dvd iso has following version, however required is 2.4.3

[root@cloud-qe-19 Packages]# rpm -qa | grep python-request
python-requests-2.2.1-1.el7sat.noarch
[root@cloud-qe-19 Packages]# pwd
/media/rhel711dvd/Packages
[root@cloud-qe-19 Packages]#
Comment 8 Sachin Ghai 2015-08-10 03:07:42 EDT
Verified with the rhel71 ISO RC2 compose. (RHEL-7-20150808.1)

The issue related to python-requests package has been resolved. Now this package is part of ISO compose RC2.

[root@cloud-qe-19 ~]# cd /media/sat61rc2/
[root@cloud-qe-19 sat61rc2]# ls
install_packages  media.repo  Packages  repodata  RHSCL  TRANS.TBL
[root@cloud-qe-19 sat61rc2]# cd Packages/
[root@cloud-qe-19 Packages]# rpm -qa | grep python-request
python-requests-2.4.3-1.el7sat.noarch


Also, upgrade from sat6.0.4 to RC2 compose on rhel71 completed successfully.

[root@cloud-qe-19 ~]# katello-installer --upgrade
Upgrading...
Upgrade Step: stop_services...
Upgrade Step: start_mongo...
Upgrade Step: migrate_pulp...
Upgrade Step: start_httpd...
Upgrade Step: migrate_candlepin...
Upgrade Step: migrate_foreman...
Upgrade Step: Running installer...
Installing             Done                                               [100%] [..................................................................]
  The full log is at /var/log/katello-installer/katello-installer.log
Upgrade Step: restart_services...
Upgrade Step: db_seed...
Upgrade Step: errata_import (this may take a while) ...
Upgrade Step: update_gpg_urls (this may take a while) ...
Upgrade Step: update_repository_metadata (this may take a while) ...
Katello upgrade completed!
Comment 9 Bryan Kearney 2015-08-12 12:03:31 EDT
This bug was fixed in Satellite 6.1.1 which was delivered on 12 August, 2015.

Note You need to log in before you can comment on or make changes to this bug.