Bug 1250811 - aarch64: WARNING: at net/core/dev.c:6012 rollback_registered_many at boot time
aarch64: WARNING: at net/core/dev.c:6012 rollback_registered_many at boot time
Status: CLOSED DUPLICATE of bug 1229220
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kernel-aarch64 (Show other bugs)
7.2
aarch64 Linux
medium Severity medium
: rc
: ---
Assigned To: arm-mgr
Jeff Bastian
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-06 00:39 EDT by Eryu Guan
Modified: 2015-08-06 09:33 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-06 09:33:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eryu Guan 2015-08-06 00:39:03 EDT
Description of problem:
After installing RHEL-7.2-20150720.0 Server aarch64 distrobution, I hit the following warning in dmesg

[    1.894905] ------------[ cut here ]------------
[    1.899502] WARNING: CPU: 0 PID: 1 at net/core/dev.c:6012 rollback_registered_many+0x90/0x318()
[    1.908159] Modules linked in:
[    1.911213] CPU: 0 PID: 1 Comm: swapper/0 Not tainted 4.1.0-0.12.el7.aarch64 #1
[    1.918483] Hardware name: AppliedMicro Mustang/Mustang, BIOS 1.1.0 Apr 22 2015
[    1.925755] Call Trace:
[    1.928190] [<fffffe000009781c>] dump_backtrace+0x0/0x170
[    1.933566] [<fffffe00000979ac>] show_stack+0x20/0x2c
[    1.938591] [<fffffe000072020c>] dump_stack+0x78/0x9c
[    1.943619] [<fffffe00000c2040>] warn_slowpath_common+0xa0/0xd8
[    1.949508] [<fffffe00000c21bc>] warn_slowpath_null+0x34/0x44
[    1.955227] [<fffffe00005eb6cc>] rollback_registered_many+0x8c/0x318
[    1.961544] [<fffffe00005eb990>] rollback_registered+0x38/0x50
[    1.967346] [<fffffe00005ed2ac>] unregister_netdevice_queue+0x54/0x8c
[    1.973756] [<fffffe00005ed308>] unregister_netdev+0x24/0x38
[    1.979385] [<fffffe0000513110>] xgene_enet_probe+0x584/0xa54
[    1.985106] [<fffffe0000489a58>] platform_drv_probe+0x4c/0xc0
[    1.990822] [<fffffe0000487870>] driver_probe_device+0x1d0/0x404
[    1.996800] [<fffffe0000487ba8>] __driver_attach+0xa8/0xb0
[    2.002261] [<fffffe000048564c>] bus_for_each_dev+0x68/0xac
[    2.007796] [<fffffe000048714c>] driver_attach+0x2c/0x38
[    2.013084] [<fffffe0000486d00>] bus_add_driver+0x16c/0x248
[    2.018626] [<fffffe0000488420>] driver_register+0x6c/0x138
[    2.024172] [<fffffe0000489974>] __platform_driver_register+0x74/0x84
[    2.030579] [<fffffe0000c3874c>] xgene_enet_driver_init+0x14/0x20
[    2.036642] [<fffffe000009083c>] do_one_initcall+0xcc/0x1cc
[    2.042189] [<fffffe0000c00b8c>] kernel_init_freeable+0x1b0/0x254
[    2.048252] [<fffffe000071a078>] kernel_init+0x14/0xe4
[    2.053371] ---[ end trace 015990076757cc92 ]---

Version-Release number of selected component (if applicable):
kernel-4.1.0-0.12.el7.aarch64

How reproducible:
not sure, but seen more than once

Steps to Reproduce:
1. install RHEL-7.2-20150720.0 Server aarch64 distrobution and boot
2.
3.

Actual results:
warning

Expected results:
no warning

Additional info:
job link https://beaker.engineering.redhat.com/recipes/2127493
hostname https://beaker.engineering.redhat.com/view/apm-mustang-ev3-28.khw.lab.eng.bos.redhat.com
Comment 1 Jeff Bastian 2015-08-06 09:05:21 EDT
Eryu, this looks like a duplicate of bug 1229220 and it's fixed in the latest 4.2.0-0.rc3.* kernels.  Can you verify if this is a duplicate?
Comment 2 Eryu Guan 2015-08-06 09:33:05 EDT
Yes, they look the same to me, I'll close this one, thanks! (my bugzilla search missed bug 1229220..)

*** This bug has been marked as a duplicate of bug 1229220 ***

Note You need to log in before you can comment on or make changes to this bug.