Bug 1250838 - fedora-packager-setup does not run
fedora-packager-setup does not run
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: fedora-packager (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-06 02:42 EDT by L.L.Robinson
Modified: 2016-05-22 05:41 EDT (History)
3 users (show)

See Also:
Fixed In Version: fedora-packager-0.5.10.7-1.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-22 05:41:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description L.L.Robinson 2015-08-06 02:42:08 EDT
Description of problem:

when I run fedora-packager-setup is does this


[baggypants@latidude ~]$ fedora-packager-setup                                  
Traceback (most recent call last):
  File "/usr/bin/fedora-packager-setup", line 21, in <module>
    import fedora_cert
  File "/usr/lib/python2.7/site-packages/fedora_cert/__init__.py", line 15, in <module>
    from fedora.client.fas2 import AccountSystem
  File "/usr/lib/python2.7/site-packages/fedora/client/__init__.py", line 121, in <module>
    from fedora.client.proxyclient import ProxyClient
  File "/usr/lib/python2.7/site-packages/fedora/client/proxyclient.py", line 67, in <module>
    import requests
  File "/usr/lib/python2.7/site-packages/requests/__init__.py", line 59, in <module>
    from .models import Request, Response, PreparedRequest
  File "/usr/lib/python2.7/site-packages/requests/models.py", line 22, in <module>
    from .packages.urllib3.exceptions import (
ImportError: cannot import name ProtocolError


Version-Release number of selected component (if applicable):
Installed Packages
Name        : fedora-packager
Arch        : noarch
Epoch       : 0
Version     : 0.5.10.5
Release     : 1.fc22
Size        : 80 k
Repo        : @System
From repo   : fedora
Summary     : Tools for setting up a fedora maintainer environment
URL         : https://fedorahosted.org/fedora-packager
License     : GPLv2+
Description : Set of utilities useful for a fedora packager in setting up their
            : environment.


How reproducible:
always

Steps to Reproduce:
1. dnf install fedora-packager
2. fedora-packager-setup
3.

Actual results:
[baggypants@latidude ~]$ fedora-packager-setup                                  
Traceback (most recent call last):
  File "/usr/bin/fedora-packager-setup", line 21, in <module>
    import fedora_cert
  File "/usr/lib/python2.7/site-packages/fedora_cert/__init__.py", line 15, in <module>
    from fedora.client.fas2 import AccountSystem
  File "/usr/lib/python2.7/site-packages/fedora/client/__init__.py", line 121, in <module>
    from fedora.client.proxyclient import ProxyClient
  File "/usr/lib/python2.7/site-packages/fedora/client/proxyclient.py", line 67, in <module>
    import requests
  File "/usr/lib/python2.7/site-packages/requests/__init__.py", line 59, in <module>
    from .models import Request, Response, PreparedRequest
  File "/usr/lib/python2.7/site-packages/requests/models.py", line 22, in <module>
    from .packages.urllib3.exceptions import (
ImportError: cannot import name ProtocolError


Expected results:
It to set up something

Additional info:
Comment 1 Till Maas 2016-05-22 05:41:45 EDT
Thank you, ti seems to be working in fedora-packager-0.5.10.7-1.fc22 right now, therefore I close this bug. If you still have this problem, please re-open this bug report or file a new one.

Note You need to log in before you can comment on or make changes to this bug.