Bug 1250846 - Installer fails with ClassNotFoundException
Installer fails with ClassNotFoundException
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Installer (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity urgent
: ER4
: 6.2.0
Assigned To: Thomas Hauser
Jan Stastny
: QA-Closed, TestBlocker
: 1250878 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-06 03:03 EDT by Andrej Smigala
Modified: 2016-02-10 03:54 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-10 03:54:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrej Smigala 2015-08-06 03:03:29 EDT
Description of problem:
The below stack trace is logged after starting the installer. When doing a GUI install, it is possible to get to the Create Users page, after which the installer hangs. When doing an automated install, it fails after the Modify pack selection step.

The console install also shows the stacktrace, but can be finished after that.


Version-Release number of selected component (if applicable):
ER4



java.lang.ClassNotFoundException: com.redhat.installer.password.validator.PasswordValidator
        at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
        at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
        at java.lang.Class.forName0(Native Method)
        at java.lang.Class.forName(Class.java:191)
        at com.izforge.izpack.installer.DataValidatorFactory.createDataValidator(DataValidatorFactory.java:34)
        at com.izforge.izpack.installer.InstallerFrame.loadPanels(InstallerFrame.java:328)
        at com.izforge.izpack.installer.InstallerFrame.<init>(InstallerFrame.java:225)
        at com.izforge.izpack.installer.GUIInstaller.loadGUI(GUIInstaller.java:695)
        at com.izforge.izpack.installer.GUIInstaller.access$100(GUIInstaller.java:54)
        at com.izforge.izpack.installer.GUIInstaller$2.run(GUIInstaller.java:241)
        at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:312)
        at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:745)
        at java.awt.EventQueue.access$300(EventQueue.java:103)
        at java.awt.EventQueue$3.run(EventQueue.java:706)
        at java.awt.EventQueue$3.run(EventQueue.java:704)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
        at java.awt.EventQueue.dispatchEvent(EventQueue.java:715)
        at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
        at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
        at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
        at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)
Comment 2 Thomas Hauser 2015-08-06 14:20:10 EDT
*** Bug 1250878 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.