This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1250856 - subscription-manager register fails with "Problem creating unit Consumer [id = <id>, type = ConsumerType [id=0, label=system], getName() = <fqdn>]" but returns 0
subscription-manager register fails with "Problem creating unit Consumer [id ...
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.7
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: candlepin-bugs
John Sefler
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-06 03:30 EDT by Jan Hutař
Modified: 2016-06-29 21:33 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-04 11:09:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2015-08-06 03:30:34 EDT
Description of problem:
Command `subscription-manager register ...` failed with "Problem creating unit Consumer [id = <id>, type = ConsumerType [id=0, label=system], getName() = <fqdn>]" but exits with 0


Version-Release number of selected component (if applicable):
subscription-manager-1.14.10-1.el6.x86_64
python-rhsm-1.14.3-1.el6.x86_64


How reproducible:
extremely rare


Steps to Reproduce:
1. # subscription-manager register --force --username <user> --password <pass>


Actual results:
Error message was:

Problem creating unit Consumer [id = <>, type = ConsumerType [id=0, label=system], getName() = amd-dinar-01.lab.bos.redhat.com]


Expected results:
In this case exit code should be !=0 IMO and error message could contain some hints.


Additional info:
Please let me know if this is expected so I can alter mine scripts to ignore this issue and just retry - or whatever would be correct thing to do.
Comment 3 Filip Nguyen 2015-11-05 12:41:58 EST
Can you please provide rhsm logs? /var/log/rhsm/rhsm.log Since its hard to reproduce we at least need to start with the exception returned from the server.
Comment 4 Jan Hutař 2015-11-06 01:43:16 EST
Sorry, unfortunately logs are gone now. Feel free to close this then.

Note You need to log in before you can comment on or make changes to this bug.