Bug 1250992 - non-configured nics are reported as 'down' even if they have carrier signal
non-configured nics are reported as 'down' even if they have carrier signal
Status: CLOSED WONTFIX
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
---
Unspecified Unspecified
medium Severity medium (vote)
: ovirt-4.0.0-alpha
: ---
Assigned To: bugs@ovirt.org
Pavel Stehlik
:
Depends On:
Blocks: 1250032
  Show dependency treegraph
 
Reported: 2015-08-06 07:44 EDT by Sahina Bose
Modified: 2016-03-27 05:21 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-27 05:21:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
danken: ovirt‑4.0.0?
ylavi: planning_ack?
ylavi: devel_ack?
ylavi: testing_ack?


Attachments (Terms of Use)
vdscaps output (13.89 KB, text/plain)
2015-08-17 03:29 EDT, Sahina Bose
no flags Details
getVdsStats output (8.97 KB, text/plain)
2015-08-17 10:22 EDT, Sahina Bose
no flags Details

  None (edit)
Description Sahina Bose 2015-08-06 07:44:05 EDT
Description of problem:

Networks sub-tab of Host, shows the network interface status as DOWN, even if the network interface is not in use

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:


Actual results:


Expected results:


Additional info:
Comment 1 Sahina Bose 2015-08-12 04:02:17 EDT
If a NIC does not have an associated IP address, can it be assumed that this is not in use, and show the status as UNASSIGNED or some other status than DOWN?
Comment 2 Dan Kenigsberg 2015-08-16 04:53:13 EDT
Would you attach the output of getVdsCaps?
Comment 3 Sahina Bose 2015-08-17 03:29:02 EDT
Created attachment 1063660 [details]
vdscaps output
Comment 4 Sahina Bose 2015-08-17 03:29:42 EDT
Only ib0 and eth2 are used.
Comment 5 Dan Kenigsberg 2015-08-17 09:29:43 EDT
I'm so sorry - I need the output of getVdsStats, which includes nics' up-state.
Comment 6 Sahina Bose 2015-08-17 10:22:10 EDT
Created attachment 1063896 [details]
getVdsStats output
Comment 7 Red Hat Bugzilla Rules Engine 2015-10-19 06:56:44 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 8 Dan Kenigsberg 2016-03-27 05:21:10 EDT
Sahina, sorry for the very slow response, but according to comment 6 all nics (apart of eth2 and ib0) are reported as 'down' by the kernel.

You might be referring to the difference between IFF_UP and IFF_LOWER_UP. Vdsm reports /sys/class/net/nic/operstate which I believe the logical AND of the two. So nics that are configured to be down, yet could have had carrier, are still reported as 'down'.

This was intentional, as their current state is not usable. It could have been nice to report  IFF_LOWER_UP as well, but we have no plans to do it in the immediate future.

Note You need to log in before you can comment on or make changes to this bug.