Bug 1251138 - Badly formatted error - "Error while executing action: Cannot ${action} ${type}"
Badly formatted error - "Error while executing action: Cannot ${action} ${ty...
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.5.4
Unspecified Unspecified
low Severity low
: ovirt-3.6.3
: 3.6.0
Assigned To: Maor
Aharon Canan
storage
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-06 10:22 EDT by Nelly Credi
Modified: 2016-03-10 01:21 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-23 09:53:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine (60.83 KB, text/plain)
2015-08-19 05:09 EDT, Maor
no flags Details
audit log message (21.19 KB, image/png)
2015-08-19 05:09 EDT, Maor
no flags Details

  None (edit)
Description Nelly Credi 2015-08-06 10:22:29 EDT
Description of problem:

string not formatted correctly 
Error while executing action: Cannot ${action} ${type}

Version-Release number of selected component (if applicable):
vt16.6

How reproducible:


Steps to Reproduce:
1.There was some problem with the disk of a template (it was gone)
2.I tried to create a vm from this template
3.I got the error: Error while executing action: Cannot ${action} ${type}. VM doesn't exist

Actual results:
Error while executing action: Cannot ${action} ${type}. VM doesn't exist

Expected results:
formatted string

Additional info:
Comment 1 Maor 2015-08-09 07:46:04 EDT
Hi Nelli,

Can you please describe a bit more what were the reproduce steps, like what was the problem with the Template's disk? and how can I reproduce it

It seems that the message you got  "Cannot ${action} ${type}. VM doesn't exist" is quite an old message (seems its origin is ACTION_TYPE_FAILED_VM_NOT_EXIST key) which was remove already at commit e432ac3d10dbb6d91fd764eb2ea15aee89181195.
What seems odd to me because this commit was already merged last year and you were using vt16.6.

If you can attach the engine and VDSM logs, I can make sure which key were used for the message, and if commit e432ac3d10dbb6d91fd764eb2ea15aee89181195 will solve this issue or not.
Comment 2 Nelly Credi 2015-08-10 05:05:13 EDT
Hi Maor,

I apologize but I dont have the logs as I assumed it will be easy to find this message in the code, but if you want to take a look at the environment, let me know (but you wont see the error as we removed this template already)

as for reproducing, we got to a situation where a template existed, but its disk was removed from the storage, so when I tried to create a vm from this template, I got this error
Comment 3 Maor 2015-08-10 06:25:44 EDT
(In reply to Nelly Credi from comment #2)
> Hi Maor,
> 
> I apologize but I dont have the logs as I assumed it will be easy to find
> this message in the code, but if you want to take a look at the environment,
> let me know (but you wont see the error as we removed this template already)

Thanks I will check this, if this can be reproduced somehow that could be great.


> 
> as for reproducing, we got to a situation where a template existed, but its
> disk was removed from the storage, so when I tried to create a vm from this
> template, I got this error
Comment 4 Maor 2015-08-12 11:45:02 EDT
I didn't managed to reproduce this, and I can see that this message has been removed.
Closing the bug for now, please re-open if you have explicit reproduce steps with the appropriate logs.
Comment 5 Raz Tamir 2015-08-13 16:47:04 EDT
Hi Maor, Nelly,
To reproduce this:
1) create a template 
2) under /rhev/data-center/ locate the template's disk (image_id)
3) it will contain 3 files: <uuid>, <uuid>.meta, <uuid>.lease
4) remove only the data file: <uuid>
Comment 6 Nelly Credi 2015-08-18 08:46:31 EDT
steps to reproduce in comment 5
Comment 7 Maor 2015-08-19 05:08:32 EDT
(In reply to ratamir from comment #5)
> Hi Maor, Nelly,
> To reproduce this:
> 1) create a template 
> 2) under /rhev/data-center/ locate the template's disk (image_id)
> 3) it will contain 3 files: <uuid>, <uuid>.meta, <uuid>.lease
> 4) remove only the data file: <uuid>

I've done that, and all I got was an audit log error saying:
"Volume does not exists"
and "Failed to complete VM some_vm creation"

Attaching the logs and a print screen
Comment 8 Maor 2015-08-19 05:09:04 EDT
Created attachment 1064690 [details]
engine
Comment 9 Maor 2015-08-19 05:09:42 EDT
Created attachment 1064691 [details]
audit log message
Comment 10 Maor 2015-08-19 05:13:33 EDT
Nelly, Raz
Can you please try to reproduce this in an oVirt 3.6 env, and if that does reproduce can u please attach the appropriate logs.
Comment 11 Maor 2015-08-23 09:53:35 EDT
Talked with Raz, the issue of the uninitialized message does not seems to be an issue, closing this bug for now.
If that re-produce please attach the appropriate logs and print screen.

Note You need to log in before you can comment on or make changes to this bug.