Bug 125114 - 2 broken calls to fputs
Summary: 2 broken calls to fputs
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: emacs   
(Show other bugs)
Version: 2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-02 20:05 UTC by d.binderman
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-29 16:09:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description d.binderman 2004-06-02 20:05:11 UTC
Description of problem:

I just tried to compile package emacs-21.3-12 from Redhat Fedora
Core2.

The compiler said

1.

/usr/src/redhat/BUILD/emacs-21.3/lib-src/ebrowse.c:1351: warning: null
argument
where non-null required (arg 1)

The source code is

      PUTSTR (NULL, fp);                /* FIXME? scope for globals */

This code needs re-work. Calling fputs with a NULL first argument 
won't work.

2.

/usr/src/redhat/BUILD/emacs-21.3/lib-src/ebrowse.c:1385: warning: null
argument
where non-null required (arg 1)

Duplicate.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jens Petersen 2004-09-29 16:08:03 UTC
Recommend taking this to emacs-devel with a patch since it is still
present in cvs.


Note You need to log in before you can comment on or make changes to this bug.