Bug 1251150 - Submit from Mellanox Technologies for MLNX mechanism driver for Networking Component on RHEL OpenStackPlatform for Kilo
Submit from Mellanox Technologies for MLNX mechanism driver for Networking Co...
Status: CLOSED WORKSFORME
Product: Red Hat Certification Program
Classification: Red Hat
Component: redhat-certification-openstack (Show other bugs)
1.0
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Rohan Kanade
Anshul Behl
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-06 10:54 EDT by Lenny Verkhovsky
Modified: 2015-08-13 10:19 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-13 10:19:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lenny Verkhovsky 2015-08-06 10:54:44 EDT
Description of problem:


Mellanox would like to certify mlnx Mechanism Driver for Neutron ML2 PLugin.
This driver supports SR-IOV Technology on Mellanox NICs 

Company Name: Mellanox Technologies
Product name and version: mlnx Mechanism Driver
Type of Product/Component: In Tree
Product license: Apache 2
Product Packaging Format: RPM
Version-Release number of selected component:
                eswitchd-0.13-1.el7.x86_64.rpm

Product Description:
mlnx Mechanism Driver for Networking Component ( Neutron )
out of tree packages: http://www.mellanox.com/repository/solutions/openstack/kilo/rhel7/
out of tree code: https://github.com/mellanox-openstack/mellanox-eswitchd

hostname: r-ufm167

Networking (Neutron) Component Specific Questions:
mlnx Driver is using VLAN technology over SR-IOV.

Support LBaas/VPNaas/FWaas - No
Hardware dependency - Mellanox ConnectX-3/ConnectX-3-Pro cards
http://www.mellanox.com/page/products_dyn?product_family=119



How reproducible:
Steps to Reproduce:
1. Follow https://wiki.openstack.org/wiki/Mellanox-Neutron-Kilo-Redhat-InfiniBand


Actual results:
Expected results:
Additional info:
Comment 1 Lenny Verkhovsky 2015-08-13 04:15:22 EDT
due to file size issue logs are uploaded here
http://144.76.193.39/RH_logs/rhel-log.tar.bz2

md5sum rhel-log.tar.bz2
e30b2d235e9d7a730da882c1344b1ae2 rhel-log.tar.bz2
Comment 2 Rohan Kanade 2015-08-13 04:20:18 EDT
Please create a new bug for certification with correct Bugzilla Summary as given in 2.2 below 

https://access.redhat.com/articles/1504393#CreateaBugzillaAccountandObtaintheNecessaryEntitlements

This will allow Certification services to correctly create Vendor/Product/Plugin records

You have to run the API test suite which is called "openstack_verify"

https://access.redhat.com/articles/1504393#RunCertificationTestsontheSoftwareUnderTest

Please send logs using webui on the new bug
https://access.redhat.com/articles/1504393#SubmittheTestLogFileforReview
Comment 3 Lenny Verkhovsky 2015-08-13 04:29:07 EDT
This bug was opened according to  
https://access.redhat.com/articles/1504393#CreateaBugzillaAccountandObtaintheNecessaryEntitlements Section 2.2
What details are incomplete or incorrect?

The logs were uploaded manually due to webui issues that are currently discussed with RedHat via emails with 'Ramakrishna Reddy Yekulla' <rreddy@redhat.com> 
Those logs were produced by running openstack_verify.

thanks.
Comment 4 Rohan Kanade 2015-08-13 04:48:19 EDT
1) Product/Component for this bug is incorrect, bug summary is incorrect. Please read [0] carefully

2) The log file is named "rhel-log.tar.bz2", the log file produced by openstack tests is "openstack-log.tar.bz2", Please read [1]


[0] : https://access.redhat.com/articles/1504393#CreateaBugzillaAccountandObtaintheNecessaryEntitlements

[1]: https://access.redhat.com/articles/1504393#RunCertificationTestsontheSoftwareUnderTest
Comment 5 Lenny Verkhovsky 2015-08-13 04:52:03 EDT
1) I will open new bug
2) I will wait for resolving webui issues, rerun and upload logs again.

thanks.
Comment 6 Rohan Kanade 2015-08-13 05:09:06 EDT
Please try below steps for resolving WebUI issues

- rhcert-backend server stop
- rhcert-backend clean all
- rhcert-backend server start --debug=high
- rhcert-backend server listener --debug=high

More info here:
https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform_Certification_Test_Suite/6/html/User_Guide/chap-Re-running_Red_Hat_OpenStack_Certification_Tests_in_Case_of_Failures.html
Comment 7 Lenny Verkhovsky 2015-08-13 10:19:36 EDT
thanks.
It did not work.

I've found another workaround
# nohup /usr/bin/python /usr/bin/rhcert-backend server listener &

I guess this bug can be closed.

Note You need to log in before you can comment on or make changes to this bug.