Bug 125121 - When you issue a cluster status command from cluadmin, the service and owner fields are limited to 14 characters
When you issue a cluster status command from cluadmin, the service and owner ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: clumanager (Show other bugs)
2.1
All Linux
low Severity medium
: ---
: ---
Assigned To: Lon Hohberger
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-02 16:28 EDT by Rich Lau
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-18 11:52:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch implementing long-output mode (12.48 KB, patch)
2004-06-07 13:13 EDT, Lon Hohberger
no flags Details | Diff
Above patch, compiler warnings cleaned up, briefly tested (12.88 KB, patch)
2004-06-07 13:17 EDT, Lon Hohberger
no flags Details | Diff
Minor updates (13.49 KB, patch)
2004-06-07 13:37 EDT, Lon Hohberger
no flags Details | Diff
Output examples (3.61 KB, text/plain)
2004-06-07 13:45 EDT, Lon Hohberger
no flags Details

  None (edit)
Description Rich Lau 2004-06-02 16:28:31 EDT
Description of problem:
When you issue a cluster status command from cluadmin, the service 
and owner fields are limited to 14 characters

Version-Release number of selected component (if applicable):
Red Hat Cluster Manager (clumanager) 1.0.19
cluadmin $Id: cluadmin.tcl,v 1.35 2002/10/02 21:48:25 lhh Exp $


How reproducible:
All the time

Steps to Reproduce:
1. Run the following command: "cluadmin -s cluster status"
2.
3.
  
Actual results:
                                         Last             Monitor  
Restart
  Service        Status   Owner          Transition       Interval 
Count
  -------------- -------- -------------- ---------------- -------- ---
----
  service2       started  usil474lnx11   14:54:30 May 18  0        0
  service1       started  usil474lnx11   14:54:30 May 18  0        0
  service3       started  usil474lnx11   14:54:30 May 18  0        0
  service4       started  usil474lnx11   14:54:29 May 18  0        0
  service5       started  usil474lnx11   14:54:30 May 18  0        0
  service6       started  usil474lnx11   14:54:30 May 18  0        0
  apache         disabled None           18:38:49 May 04  30       0
  service7       started  usil474lnx11   14:54:30 May 18  0        0
  service8       started  usil474lnx11   14:54:30 May 18  0        0
  service11      started  usil474lnx11   14:54:30 May 18  0        0
  service12      started  usil474lnx11   14:54:30 May 18  10       0
  service13      disabled None           19:28:32 May 04  5        0


Expected results:


Additional info:
The problem is that the service and owner field are both limited to 
14 characters in this display.  If the hostname of node A 
was "abcdefghijklmn1" and the host of node B was "abcdefghijklmn2", 
for example, then in this display the last character would be cutoff 
and therefore the user would have no idea which service belonged to 
what node.
Comment 1 Lon Hohberger 2004-06-03 09:29:31 EDT
Note that "cluadmin -- cluster status" is the long way around simply
typing "clustat".

To "fix" this:

(1) It would be better to add a command line option to enable a
different output method, rather than simply altering the field widths.

(2) Having a "minimum size" and no "max" size might also work. 
However, the output will be very messy in this case (it will run on to
the next line...)

Comment 3 Lon Hohberger 2004-06-07 13:13:01 EDT
Created attachment 100928 [details]
Patch implementing long-output mode

Adds long output mode to clustat.

Note that "service show state" and "cluster status" commands from within
cluadmin will still not work; in order to determine the status you're looking
for, you must use clustat directly.
Comment 4 Lon Hohberger 2004-06-07 13:17:40 EDT
Created attachment 100929 [details]
Above patch, compiler warnings cleaned up, briefly tested

Tested only briefly
Comment 5 Lon Hohberger 2004-06-07 13:37:29 EDT
Created attachment 100933 [details]
Minor updates

Minor output bugfixes.	Should be final iteration; please test.
Comment 6 Lon Hohberger 2004-06-07 13:45:40 EDT
Created attachment 100934 [details]
Output examples

Output of clustat with and without -l flag for normal, -p <service>, -m
<member>, and -c <channel> operations.
Comment 8 Derek Anderson 2004-06-16 11:00:18 EDT
Verified long listing of clustat output.  Marking PROD_READY.
Comment 9 John Flanagan 2004-08-18 11:52:56 EDT
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-223.html

Note You need to log in before you can comment on or make changes to this bug.