Bug 1251268 - Systems -> Insights -> Setup: "Select All" button should select all systems, not only these currently displayed
Systems -> Insights -> Setup: "Select All" button should select all systems, ...
Status: NEW
Product: Red Hat Satellite 5
Classification: Red Hat
Component: redhat-access-plugin-sat5 (Show other bugs)
570
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Chris Kyrouac
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-06 16:56 EDT by Jan Hutař
Modified: 2016-07-03 21:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2015-08-06 16:56:23 EDT
Description of problem:
Button "Select All" on Systems -> Insights -> Setup page "Select All" button should select all systems, not only these currently displayed. This way it would be consistent with rest of Satellite 5 webUI.


Version-Release number of selected component (if applicable):
redhat-access-plugin-sat5-2.0.0-42.el6.noarch


How reproducible:
always


Steps to Reproduce:
1. Have Sat5 with RHAI enabled and, say, 20 systems registered
2. Go to Systems -> Insights -> Setup and notice that by default 10 systems
   are displayed
3. Click "Select All" button
4. Click ">" button to display another 10 systems


Actual results:
Only first 10 system was checked/selected. The other 10 systems were not selected.


Expected results:
All 20 systems should be selected by clicking on "Select All" button - this way it would be consistent with rest of Satellite 5 webUI


Additional info:
Compare this behaviour to Systems (shows 25 systems by default). In my case all 1256 systems was selected by clicking on "Select All" button. You can check number of selected systems in upper right corner of the screen next to "Manage" and "Clear" buttons.
Comment 1 Jan Hutař 2015-08-06 16:59:15 EDT
Sorry, for some reason I have chosen incorrect component. Fixing.

Note You need to log in before you can comment on or make changes to this bug.