Bug 1251272 - rhnlib-2.5.75.1-el7 - from rhn.connections import idn_ascii_to_pune error
rhnlib-2.5.75.1-el7 - from rhn.connections import idn_ascii_to_pune error
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rhn-client-tools (Show other bugs)
7.1
x86_64 Linux
unspecified Severity urgent
: rc
: ---
Assigned To: Clifford Perry
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-06 17:03 EDT by Gary
Modified: 2015-08-10 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-10 11:37:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
config.py patch (408 bytes, text/plain)
2015-08-06 17:03 EDT, Gary
no flags Details
patches for tui.py config.py and rhnreg_ks (10.00 KB, application/x-tar)
2015-08-06 17:38 EDT, Gary
no flags Details

  None (edit)
Description Gary 2015-08-06 17:03:22 EDT
Created attachment 1060091 [details]
config.py patch

Description of problem:


Version-Release number of selected component (if applicable):
2.5.75.1-el7

How reproducible:
always

Steps to Reproduce:
1. install package like rhn-check
2. run rhn-check


Actual results:
traceback:
from rhn.connections import idn_ascii_to_pune error

Expected results:
OK

Additional info:
typo found in component. patch attached.
Comment 1 Gary 2015-08-06 17:20:45 EDT
file in question:
/usr/share/rhn/up2date_client/config.py
Comment 3 Gary 2015-08-06 17:37:06 EDT
Err.. just trying to register a machine and I can not. Found this issue elsewhere as well like in the rhn-setup rpm.

Attached are more patches, please disregard the previous patch see new ones.

/usr/sbin/rhnreg_ks
/usr/share/rhn/up2date_client/tui.py
/usr/share/rhn/up2date_client/config.py
Comment 4 Gary 2015-08-06 17:38:15 EDT
Created attachment 1060110 [details]
patches for tui.py config.py and rhnreg_ks

tar file with 3 patches.
Comment 5 Gary 2015-08-06 22:00:34 EDT
my repo was out of date, this is already patched.
closing.
Comment 6 Tomas Lestach 2015-08-10 11:37:45 EDT
There is no released version of rhnlib-2.5.75.1 on rhel7 (not even upstream).
If you experience the puny<->pune issue, make sure you update all the rhel client packages, especially rhnlib (and rhn-client-tools).

Closing as this issue was solved time ago.

Actually, if you should experience any other issues in the future, please, make sure you open a ticket with Red Hat Support. Thank you.

Note You need to log in before you can comment on or make changes to this bug.