Bug 1251275 - link to info about Smart Variables (when editing puppet class) is broken
link to info about Smart Variables (when editing puppet class) is broken
Status: CLOSED DUPLICATE of bug 1289540
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Branding (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity low (vote)
: Beta
: --
Assigned To: Shimon Shtein
Jitendra Yejare
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-06 17:28 EDT by Jan Hutař
Modified: 2016-04-27 04:45 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-22 02:34:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2015-08-06 17:28:04 EDT
Description of problem:
Link to info about Smart Variables (when editing puppet class) is broken.


Version-Release number of selected component (if applicable):
Satellite-6.1.0-RHEL-6-20150731.1-Satellite-x86_64


How reproducible:
always


Steps to Reproduce:
1. Ensure you have some Puppet class
2. Configure -> Puppet classes -> <some_class> -> Smart Variables
3. Note the link in the hint there "Help! What is a Smart variable?"


Actual results:
Link points to:

https://access.redhat.com/documentation/en-US/Red_Hat_Satellite/6.1/html/User_Guide/Configuring_Smart_Parameters.html which is giving 404


Expected results:
Maybe this is because there is only Beta doc on docs.redhat.com. But When I have searched chapter which was probably expected goal, I have found this:

https://access.redhat.com/documentation/en-US/Red_Hat_Satellite/6.1/html/User_Guide/sect-Red_Hat_Satellite-User_Guide-Configuring_the_Provisioning_Environment-Parameters.html#sect-Red_Hat_Satellite-User_Guide-Configuring_Smart_Parameters

This seems too different.
Comment 2 Brad Buckingham 2015-11-19 18:25:11 EST
Created redmine issue http://projects.theforeman.org/issues/12545 from this bug
Comment 3 Bryan Kearney 2015-11-19 20:04:41 EST
Upstream bug component is Provisioning
Comment 7 Shimon Shtein 2016-04-03 08:20:52 EDT
Responded on the MR, Andrew?
Comment 11 Shimon Shtein 2016-04-21 01:11:28 EDT
If you are interested, you can verify the link by changing the server name (manually) to https://access.stage.redhat.com (add "stage" after "access"). This is the non-final version of the documentation provided by our docs team.

Note You need to log in before you can comment on or make changes to this bug.