This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 125128 - kcontrole shows wrong memory info >4GB
kcontrole shows wrong memory info >4GB
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kdebase (Show other bugs)
3.0
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-02 17:38 EDT by Gary Lerhaupt
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-12 13:38:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gary Lerhaupt 2004-06-02 17:38:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; 
H010818; .NET CLR 1.0.3705)

Description of problem:
For systems with >4GB of memory, kcontrol (KDE graphical memory 
display) only shows 3.5GB of total memory.  Likewise, other memory 
amounts are also wrong.

Version-Release number of selected component (if applicable):
kdebase-3.1.3-5.2

How reproducible:
Always

Steps to Reproduce:
1. install KDE on system with >4GB RAM
2. run kcontrol
3. click on memory tab and note memory info is wrong
    

Actual Results:  3.5 GB total memory

Expected Results:  16GB memory

Additional info:

Interestingly, it appears the maintainer of this project did try to 
account for large memory systems.  In kcontrol/info/memory.h, it 
states:

#ifdef HAVE_LONG_LONG
typedef unsigned long long t_memsize;
#else
typedef unsigned long t_memsize;
#endif

Either HAVE_LONG_LONG is not defined or perhaps later something else 
is not properly reading the memory from the syscall in 
kcontrol/info/memory_linux.cpp.
Comment 1 John Feeney 2007-07-12 13:38:46 EDT
With RHEL3 now in maintenance mode, where only critical customer issues
can be fixed, this bugzilla has been closed as wont fix due to its severity
level and a lack of recent activity. 

Note You need to log in before you can comment on or make changes to this bug.