This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1251327 - backport EC fast reads
backport EC fast reads
Status: CLOSED NEXTRELEASE
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RADOS (Show other bugs)
1.3.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 1.3.4
Assigned To: Samuel Just
ceph-qe-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-06 21:45 EDT by Sage Weil
Modified: 2017-07-30 11:12 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-03 17:27:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Ceph Project Bug Tracker 12316 None None None Never

  None (edit)
Description Sage Weil 2015-08-06 21:45:45 EDT
Backport EC fast read feature from Yahoo to hammer/1.3.x:

  https://github.com/ceph/ceph/pull/5309

This optionally lowers the latency on reads from an EC pool at the expense of a bit of extra wasted IO and CPU by reading from all shards and decoding once K out of K+M replies come back.
Comment 2 Ken Dreyer (Red Hat) 2016-08-03 15:46:29 EDT
It looks like this was fixed in some version of Hammer but I can't tell which version.
Comment 3 Samuel Just 2016-08-03 17:19:11 EDT
This hasn't been backported to hammer.  I don't really think it's a good idea.
Comment 4 Ken Dreyer (Red Hat) 2016-08-03 17:27:06 EDT
Thanks Sam. Looks like the feature is in Jewel so users can upgrade to RHCS 2 for this.

Note You need to log in before you can comment on or make changes to this bug.